Community Forum

Xfinity box won’t turn on

Regular Visitor

Xfinity box won’t turn on

Hello,

I am having an issue with my box not turning when I power on the tv with my X1 remote. The box seems to be in sleep mode and the “Power” button on the Xfinity remote will not wake it up out of sleep mode. I do not have the power save option turned on. The only way to turn on/wake up my box when it won’t respond is to physically unplug it from the back and then plug it back in. The light on the front of the box never turns off, even when it won’t respond (not sure if this means anything). This is my second box with Comcast because of this issue and it will not fix it. Any help is appreciated. I have a Toshiba TV.
Silver Problem Solver

Re: Xfinity box won’t turn on


@Redbird_2016 wrote:
Hello,

I am having an issue with my box not turning when I power on the tv with my X1 remote. The box seems to be in sleep mode and the “Power” button on the Xfinity remote will not wake it up out of sleep mode. I do not have the power save option turned on. The only way to turn on/wake up my box when it won’t respond is to physically unplug it from the back and then plug it back in. The light on the front of the box never turns off, even when it won’t respond (not sure if this means anything). This is my second box with Comcast because of this issue and it will not fix it. Any help is appreciated. I have a Toshiba TV.

All my X1 boxes have a power on/off switch.  If they do not have a light on the box, I use the power button to turn on the box.  Check the power save setup and let us know what it says.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Regular Visitor

Re: Xfinity box won’t turn on

Hi,

I do not have a Power button on my box. When I press the “power button” on Xfinity remote the TV goes on, but I get a black screen (the white light on my box is on however). Because I don’t get a “no signal” screen but instead just a black screen, it leads me to believe the box is just not responding? Power saver is off in Xfinity settings and always has been.
Regular Visitor

Re: Xfinity box won’t turn on

This forum (and there are many more out there explain my issue) looks like Comcast hasn’t found a solution: https://forums.xfinity.com/t5/TV-Archive/Xfinity-XG1v4-Black-Screen-Lock-Up/td-p/3049524
Silver Problem Solver

Re: Xfinity box won’t turn on


@Redbird_2016 wrote:
Hi,

I do not have a Power button on my box. When I press the “power button” on Xfinity remote the TV goes on, but I get a black screen (the white light on my box is on however). Because I don’t get a “no signal” screen but instead just a black screen, it leads me to believe the box is just not responding? Power saver is off in Xfinity settings and always has been.

Which X1 box do you have?

https://www.xfinity.com/support/articles/x1-hub-vs-companion-box

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Regular Visitor

Re: Xfinity box won’t turn on

XG1v4-A
Expert

Re: Xfinity box won’t turn on

it appears that my xg1v4 at random times? or aftr an update to the XRE or firmware version is not loading settings that turn off power save function so the box goes into power save that shuts off the video HDMI link with the TV. I, too, thought the box was 'off' but found if i change input on my TV (that the set top box is connected) to another live HDMI port and then right back to DVR the video and sound is restored and the buffer for the channel the set top box is on is intact (can scroll back in the buffer an hour). I had an xg1v3 previously.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: Xfinity box won’t turn on

Hello, Redbird_2016!

I'd like to help with this issue. It looks like you have gotten some great feedback thus far. @Rustyben made a great suggestion, can you try just changing the input on your tv back and forth the next time you experience this issue and see if that helps? It may not stop the issue altogether, but it may be an easier fix than having to get up and unplug the box until we are able to find a more permanent solution. I look forward to your next update.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Xfinity box won’t turn on

Hello,

Thanks for the suggestion. Unfortunately the issue happened again this morning and switching between different live inputs did not resolve the problem. I had to revert back to unplugging my box.
Expert

Re: Xfinity box won’t turn on


@Redbird_2016 wrote:
Hello,

Thanks for the suggestion. Unfortunately the issue happened again this morning and switching between different live inputs did not resolve the problem. I had to revert back to unplugging my box.

did you check to be sure power save function is 'off' and did you change to an active device/HDMI port and after video displays then changing back to the DVR?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Xfinity box won’t turn on

Yes I did, still no luck. Any other suggestions? Other forums are appearing with the same issue and no one can seems to fix it.
Silver Problem Solver

Re: Xfinity box won’t turn on


@Redbird_2016 wrote:
Hello,

I am having an issue with my box not turning when I power on the tv with my X1 remote. The box seems to be in sleep mode and the “Power” button on the Xfinity remote will not wake it up out of sleep mode. I do not have the power save option turned on. The only way to turn on/wake up my box when it won’t respond is to physically unplug it from the back and then plug it back in. The light on the front of the box never turns off, even when it won’t respond (not sure if this means anything). This is my second box with Comcast because of this issue and it will not fix it. Any help is appreciated. I have a Toshiba TV.

Can you post the details of how your TV and X1 box are connected to each other?

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!