Community Forum

XG1V4 box HDMI handshake problem

Expert

Re: XG1V4 box HDMI handshake problem

Comcast has not yet announced when the fix is ready for the 'wake up' issue with some TVs and the XG1v4 4k/UHD set top box. The simplist workaround is to change the TV HDMI input to any other port and then back to the HDMI port the set top box is connected. That way no reboot is necessary and you don't lose the current channel's buffer. 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XG1V4 box HDMI handshake problem

Yes I too have had this problem since getting the 4k box. I have a 78'' RCA however it's rumored to be a rebranded Samsung so this isn't surprising. Tried two different boxes and had Comcast try persistently to send a tech out to look at the issue which I refused as we all know it's nothing to do with anything but the box. There's been maybe five forums here about this since the issue started but comcast closes them all with someone claiming a resolution at the end which does not work. I too have been unable to have anyone at Comcast admit the problem. It's ridiculous with the prices they charge they can't or won't resolve this but don't expect anything anytime soon as this has been going on over a year now. Looking at options from RCN and AT&T now as this is unbearable.  

Contributor

Re: XG1V4 box HDMI handshake problem


@EricinChicago wrote:

Yes I too have had this problem since getting the 4k box. I have a 78'' RCA however it's rumored to be a rebranded Samsung so this isn't surprising. Tried two different boxes and had Comcast try persistently to send a tech out to look at the issue which I refused as we all know it's nothing to do with anything but the box. There's been maybe five forums here about this since the issue started but comcast closes them all with someone claiming a resolution at the end which does not work. I too have been unable to have anyone at Comcast admit the problem. It's ridiculous with the prices they charge they can't or won't resolve this but don't expect anything anytime soon as this has been going on over a year now. Looking at options from RCN and AT&T now as this is unbearable.  


Thanks for your post.  Not sure if I am going to change or just keep dealing with.   As seen through this forum it is Nation wide issue with the X1 box.   Just an update with my particular issue.  Previously I had to restart the box when turning on in the morning every 2/3 days.  For  the last 10 days it has been every other day.   

Expert

Re: XG1V4 box HDMI handshake problem


@EricinChicago wrote:

Yes I too have had this problem since getting the 4k box. I have a 78'' RCA however it's rumored to be a rebranded Samsung so this isn't surprising. Tried two different boxes and had Comcast try persistently to send a tech out to look at the issue which I refused as we all know it's nothing to do with anything but the box. There's been maybe five forums here about this since the issue started but comcast closes them all with someone claiming a resolution at the end which does not work. I too have been unable to have anyone at Comcast admit the problem. It's ridiculous with the prices they charge they can't or won't resolve this but don't expect anything anytime soon as this has been going on over a year now. Looking at options from RCN and AT&T now as this is unbearable.  


Samsung does not make a 78 inch UHD television.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: XG1V4 box HDMI handshake problem

I found 2 solutions to this problem.
1)On your Xfinity remote go to settings, device settings,power preference, and turn your power saver ON. Box will go to sleep at night but when you turn your tv on in the am it will turn the box on also. When both the box and tv turn on together the video will connect with no problem.
2) If you have a Samsung tv or a tv with the HDMI UHD COLOR setting turn it off for the HDMI cable box input. Per Samsung this setting must be on for any type of gaming because it increases the refresh rate but for a cable box with 4K it has no effect. I have mine turned off and it’s been working every morning for the last week and the 4K does come thru on Netflix.
Contributor

Re: XG1V4 box HDMI handshake problem


@jmg1951 wrote:
I found 2 solutions to this problem.
1)On your Xfinity remote go to settings, device settings,power preference, and turn your power saver ON. Box will go to sleep at night but when you turn your tv on in the am it will turn the box on also. When both the box and tv turn on together the video will connect with no problem.
2) If you have a Samsung tv or a tv with the HDMI UHD COLOR setting turn it off for the HDMI cable box input. Per Samsung this setting must be on for any type of gaming because it increases the refresh rate but for a cable box with 4K it has no effect. I have mine turned off and it’s been working every morning for the last week and the 4K does come thru on Netflix.

Thanks for your suggestions.  #1 That’s how mine is currently set.  

#2 I’ve never tried that.  I just changed and will see what happens.  I’ll let you know. I sure hope that works. 

Expert

Re: XG1V4 box HDMI handshake problem

simplest work-around is to change the TV to a different live HDMI port then back to the DVR port.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: XG1V4 box HDMI handshake problem


@Rustyben wrote:

simplest work-around is to change the TV to a different live HDMI port then back to the DVR port.


Tried that previously. Does not work for me 

Frequent Visitor

Re: XG1V4 box HDMI handshake problem

Tried that and also disconnecting the HDMI cable and plugging it back in which didn’t work for me. The fix might be different for everyone, ultimately Comcast should be fixing this , not us trying work arounds.
New Poster

Re: XG1V4 box HDMI handshake problem

Here's my latest: Called tech support. Rep said this should not be happening but did not seem to be aware of the problem or this forum. A tech came out and decided to replace the 4K box, which worked, but after the tech left the same problem occurred. Called it in again, the same tech came out and said the local engineer suggested using HDMI port #1 instead of port #2 on my Sony TV. I tried this before, but this time it worked, although there's about a 0.5 s delay to connect vs instantaneous before the problem arose. So everything's been working fine for about 2 weeks - hope it won't recur after I send this message!  I did have to spend over an hour explaining the same situation to 2 different tech support staffers and the onsite tech. The tech reps seem to think that Comcast's working on this problem, but who knows.

Contributor

Re: XG1V4 box HDMI handshake problem

Great to hear that.  In our case, for awhile, the DVR box was actually ok (i.e., TV worked fine) but the issue shifted to our two other boxes with two different issues every morning.  Xfninity was out a few times . . . today they changed the DVR box to a different one.  We'll see what happends after the next update tonight.  

I know the box changes have not worked before (this is our 3rd or 4th) but maybe they have done something since we were OK at the main box for the past couple of weeks.

I'll write back in a few days to update everyone.

New Poster

Re: XG1V4 box HDMI handshake problem

Same problem here - black screen with no audio or video every few days. Very annoying and I've found only power cycle fixes. I will try the TV HDMI input change next time it happens . My equipment: XG1-v4-A, Denon AVR-X4400W Receiver, Sony XBR940D 75", Comcast 4K high speed HDMI cable from X1 to AVR; 4k high speed cable using ARC from TV to AVR. 

 

Hoping a fix comes soon otherwise I am swapping this out to older box as there really is no benefit to the 4k box vs 1080p. Netflix is way better on the Android  Sony TV app with Atmos support and a cleaner picture.

Contributor

Re: XG1V4 box HDMI handshake problem

Back yesterday to black screen on DVR but other TVs ok. Today, all ok. Tech coming again tomorrow. If no solution, going to switch back to. FIOS who now has 4K box and voice remote. They pay switching costs. But I need Comcast to take back X1 Pods.
Contributor

Re: XG1V4 box HDMI handshake problem

Good News.  SO FAR  I have not had the problem since I tried your suggestio to turn off the UHD setting to the HDMI port that the  X1 box is connected to.    It has been 10 days since I changed the setting and have not experienced the black screen issue. 

Prior to that I had to restart the X1 every 2/3 days to get a picture on the TV.  

Thank you for your suggestion.   I have been having this problem for months and tried everything people on this forum suggested.   Nothing worked till you mentioned this.

Hopefully it stays like this.

 


@rlee131 wrote:

@jmg1951 wrote:
I found 2 solutions to this problem.
1)On your Xfinity remote go to settings, device settings,power preference, and turn your power saver ON. Box will go to sleep at night but when you turn your tv on in the am it will turn the box on also. When both the box and tv turn on together the video will connect with no problem.
2) If you have a Samsung tv or a tv with the HDMI UHD COLOR setting turn it off for the HDMI cable box input. Per Samsung this setting must be on for any type of gaming because it increases the refresh rate but for a cable box with 4K it has no effect. I have mine turned off and it’s been working every morning for the last week and the 4K does come thru on Netflix.

Thanks for your suggestions.  #1 That’s how mine is currently set.  

#2 I’ve never tried that.  I just changed and will see what happens.  I’ll let you know. I sure hope that works. 


 

Frequent Visitor

Re: XG1V4 box HDMI handshake problem

That’s what I did on my LG once the UHD setting was turned off it works with the 4K setting for regular TV. If I switch to Netflix via X1 box for an UHD movie, the tv will automatically switch to UHD on. However when I switch back to regular tv, it will lose signal and go black. I then have to manually turn off UHD on the tv for it to work. It looks like a compatibility issue since Comcast doesn’t offer any 4K programs for regular tv. My guess is the tv is looking for the signal that doesn’t exist yet and just gives up.
Contributor

Re: XG1V4 box HDMI handshake problem

Techs came out today. They set box to power down when TV is off. They were convinced this will work with my Samsung TV. BTW, the UHD setting to the HDMI has been off. I’ll write again once I see if this works.
Expert

Re: XG1V4 box HDMI handshake problem


@BrianHCM1 wrote:
That’s what I did on my LG once the UHD setting was turned off it works with the 4K setting for regular TV. If I switch to Netflix via X1 box for an UHD movie, the tv will automatically switch to UHD on. However when I switch back to regular tv, it will lose signal and go black. I then have to manually turn off UHD on the tv for it to work. It looks like a compatibility issue since Comcast doesn’t offer any 4K programs for regular tv. My guess is the tv is looking for the signal that doesn’t exist yet and just gives up.

On my 2015 3D UHD Samsung TV the UHD color setting can be set "on" or "off" for each individual HDMI port. For IPV (Internet broadband) UHD color setting is always "on" as it should be.   Check your LG manual to set if your's works that way. My tv never switches them from where I set them.

 

A possible exception might be if your television just received a "Update", or if you selected a "Reset to factory default settings.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: XG1V4 box HDMI handshake problem

Glad to hear it works for you too! Mine has been working 3 weeks without a problem.

Frequent Visitor

Re: XG1V4 box HDMI handshake problem

Don't give up on Comcast yet, they have been working on the problem. Last week Comcast called me on a update they wanted to send to my box to see if there were any changes. Sorry to say the updated did not correct the condition but at least their working on solutions. 

Frequent Visitor

Re: XG1V4 box HDMI handshake problem

If I switch the UHD Color onnor off I also get a black screen , Comcast is working on the problem because I heard from them last week.

Frequent Visitor

Re: XG1V4 box HDMI handshake problem

Letting the DVR box go into sleep mode worked for me even though I'm using the UHD Color off on my TV. When youn turn the tv on in the morning the box should wake up also as long as your remote is programed correctly to tun the tv and box at the same time. When the box and tv turn on together they both are looking for a video signal at the same time and connect with no problem.

Contributor

Re: XG1V4 box HDMI handshake problem

Amazing that you have been able to get Comcast to say they are working on it. In my area I gave had three technicians out to my house, 4 telephone conversations with support (two times with supervisors I requested to speak to) replaced the X1 box twice, and one visit to the Xfinity store  EVERYONE says they have no knowledge of the problem and it must be my TV. 

Anyway your suggestion to turn off UHD to the HDMI port WORKED so all is good now

one issue that has shown up is that even though the X1 is set to power saver every couple of days in the morning before turning the system on the light on the X1 is already on so it did not turn off since I last shut down the TV ( 14 hours 

not worried about because your fix took care of the HANDSHAKE issue Would love to connect your Comcast people with those supporting this area 

Contributor

Re: XG1V4 box HDMI handshake problem

My tech said light won’t go off but box goes to sleep. Today I was good but we’ll see tomorrow.
Frequent Visitor

Re: XG1V4 box HDMI handshake problem

Right the light on the box doesn’t go off . Glad it’s working for you so far.
Contributor

Re: XG1V4 box HDMI handshake problem

Acturally the light on my box in power saving mode does go off after a couple of hours after the tv is turned off.   Then in the morning it does not go on till I hit the remote turning on the box, Sound and TV.   This happend all the time until I change the HDMI setting that fixed the handshake.   Now when I get up in the morning about 50% of the time the X1 box light is on unlike previously when the the was not on till I hit the remote.  

Not a big deal, dont really care about the power saving mode its just that  for some reason it does not function as it did befor