Community Forum

links in email no longer opening

Regular Visitor

links in email no longer opening

Links in xfinity email (Chrome Browser) are no longer opening, so no shopping sites, no facebook link, etc. Although this was presented previously, this just started yesterday (1/31/2019) for me.

Expert

Re: links in email no longer opening


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session. If that doesn't do it, then try using a different browser.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: links in email no longer opening

Clearing the cache and restarting worked--one time. Yes, another browser will also work--but the point is I want my comcast xfinity account to work properly without having to reset my passwords and answer security questions every time I open the machine. Why  isn't comcast addressing this programming problem? And it must be recent since this only started a few days ago.

Thank you for your help.

Expert

Re: links in email no longer opening


@JVG wrote:

Clearing the cache and restarting worked--one time. Yes, another browser will also work--but the point is I want my comcast xfinity account to work properly without having to reset my passwords and answer security questions every time I open the machine. Why  isn't comcast addressing this programming problem? And it must be recent since this only started a few days ago.

Thank you for your help.


I don't think it's a programming issue with Comcast.  I use Chrome as my default browser on both my Mac desktop and my Dell Windows 10 laptop, and I cannot duplicate what you are describing on either one of them.  Links work just fine for me.  You could try disabling any extensions you have in Chrome, and/or reset it to the original specs.  In Chrome Settings, go to Advanced settings, then scroll all the way down to the bottom and you will see the option to reset it.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Comcast mail hyperlinks

I couldn't connect.  So, I turned off my pop-up blocker and reset it.  Now the hyperlinks work.  Just a thought for those with the same problem.

New Poster

Re: links in email no longer opening

I cannot open links inside of my xfinity comcast emails for some reason.  Some medical supplies are to be delivered and they sent an email with a link to  read and "agree" with, but cannot open the link.  that has been going on for a few days now, and today, another email with a link, that nothing happens.  I use Chrome.

Expert

Re: links in email no longer opening


@Owiesgirl wrote:

I cannot open links inside of my xfinity comcast emails for some reason.  Some medical supplies are to be delivered and they sent an email with a link to  read and "agree" with, but cannot open the link.  that has been going on for a few days now, and today, another email with a link, that nothing happens.  I use Chrome.


As posted upthread, right-click on the link and then open it in another tab or window.  This seems to be mostly a Chrome issue right now.  Or, use another browser.  The links work fine when I use Firefox.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: links in email no longer opening

Been on the phone four times and in live chat once to report this problem. I'm so frustrated I could burst! Besides not speaking English I can easily understand, the Xfinity reps claim to know nothing about this situation, even though I found evidence that it was reported as far back as January, 2018. At that time, Xfinity closed down the forum on hyperlink unavailablity saying "Content in this area has been identified as outdated or irrelevant."  I feel for you.  

Expert

Re: links in email no longer opening


@pootieville84 wrote:

Been on the phone four times and in live chat once to report this problem. I'm so frustrated I could burst! Besides not speaking English I can easily understand, the Xfinity reps claim to know nothing about this situation, even though I found evidence that it was reported as far back as January, 2018. At that time, Xfinity closed down the forum on hyperlink unavailablity saying "Content in this area has been identified as outdated or irrelevant."  I feel for you.  


***Validated Best Answer as of 04/2019***

 

If you are using Chrome, try:

 

  1. Click the Chrome menu on the browser toolbar.
  2. Select Settings.
  3. Click Show advanced settings.
  4. in the "Privacy" section, click the Content settings button.
  5. In the "Pop-ups" section, select "Allow all sites to show pop-ups." Customize permissions for specific websites by clicking Manage exceptions.

 

Source: https://forums.xfinity.com/t5/Email-Web-Browsing/nothing-happens-when-I-click-on-a-hyperlink-in-an-e...

 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: links in email no longer opening

I had the same thing after the screw up a few days ago on comcast email where i couldn't get into it at all for two days..  look at your browser and next to it there's a tiny red dot.. if you right click it  it asks about blocking pop ups, mine was on to block them, so i took it off, and now the hyperlinks work.. don't ask me why, i know nothing about computers, but this did work for me. 

New Poster

Re: links in email no longer opening

I could not locate any little red dots. Thank you for trying to help. It’s very disheartening not to know what changed and can’t fix.
Regular Visitor

Re: links in email no longer opening

look in your browser window at the top, its not a "dot"  now that i look.. its a square with a red x in it.. it is a popup blocker..  maybe yours looks a little different.. ive got window seven still.. but somplace on there , there is a popup blocker choice.. see if you can find it.. ? 

New Poster

Re: links in email no longer opening

I'm having the same problem but if I right click on the link and open it in a new window it works.  It's annoying - (what about Comcast isn't?) but it works.

New Poster

Re: links in email no longer opening

I tried this and it did work!  thank you for your help, and yes that is annoying, but at least able to open the links now.  Also, another party suggested for Comcast to hit the box in red with an X in it (it was on my windows 8.1 on the right hand side of the top of the browser screen, BUT only when I opened a second window so I also hit that x and maybe it also helped as I just tried again opening a link in an email and it worked ok, so one of these suggestions must have worked!  Now my latest issue is that even though I said I want Chrome to be the browser that comes up, it now comes up with a G and then a screen with everal choices, and I have to pick xfinity to get the browser screen I used to have.  And the beat goes on!!!  Thank you

New Poster

Re: links in email no longer opening

I did find that little square box with the x in it, but only when I opened a second window in Chrome.  I clicked it and also followed the advise of another answer by opening a second window when you try to open the link and that worked also.  But now it seems to work ok again without opening the second window.  So not sure what actually was the solution, but it seems to be back in working order again, though my new issue is that when I open Chrome, it comes up with a G (Google) and then a list of options to use, so I pick xfinity (I have Comcast xfinity) and then I can get the page I'm used to seeing, so weird, but I will try to figure out how to get my old crhome browser page to be the page to appear again, just glad to have the link issue apparently working again.  I think you for your help!!!  

Regular Visitor

Re: links in email no longer opening


@Owiesgirl wrote:

I tried this and it did work!  thank you for your help, and yes that is annoying, but at least able to open the links now.  Also, another party suggested for Comcast to hit the box in red with an X in it (it was on my windows 8.1 on the right hand side of the top of the browser screen, BUT only when I opened a second window so I also hit that x and maybe it also helped as I just tried again opening a link in an email and it worked ok, so one of these suggestions must have worked!  Now my latest issue is that even though I said I want Chrome to be the browser that comes up, it now comes up with a G and then a screen with everal choices, and I have to pick xfinity to get the browser screen I used to have.  And the beat goes on!!!  Thank you


GLAD IT WORKED FOR YOU !!  I have no idea why it did, but after looking all over the internet and having no luck, i figured i might as well hit everything i can find til something happens.. sheer LUCK.. lol

New Poster

Re: Comcast mail hyperlinks

How do you "turn off the pop-up blocker and re-set it?"  I have been struggling with this for several weeks.  I thought maybe I'd done something to the security options.

Expert

Re: Comcast mail hyperlinks


@Sussass wrote:

How do you "turn off the pop-up blocker and re-set it?"  I have been struggling with this for several weeks.  I thought maybe I'd done something to the security options.


Assuming you mean Chrome, see here---------------

 

https://forums.xfinity.com/t5/Email-Web-Browsing/nothing-happens-when-I-click-on-a-hyperlink-in-an-e...



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: links in email no longer opening

I've been having the same problem for about a week.  Glad to know I'm not the only one!  Comcast should be addressing this issue and correctin the problem.  Not sure why we have to open additional pages to view links.  It's an inconvenience for their suscribers.  I have a different carrier for my phone and no problems there.  Don't bother with the survery.  After trying a couple of times, I found that if you give them a low grade on the would you recommend Comcast question, you will receive the following:

An Unexpected Error has occurred.
  • Your request failed. Please contact your system administrator and provide the date and time you received the error and this Exception ID: 1B75FD85.

    Click your browser's Back button to continue.

New Poster

Re: links in email no longer opening

Thanks for your info
Regular Visitor

Re: Comcast mail hyperlinks


@Latoque wrote:

@Sussass wrote:

How do you "turn off the pop-up blocker and re-set it?"  I have been struggling with this for several weeks.  I thought maybe I'd done something to the security options.


Assuming you mean Chrome, see here---------------

 

https://forums.xfinity.com/t5/Email-Web-Browsing/nothing-happens-when-I-click-on-a-hyperlink-in-an-e...


in your browser..  on mine , i have two boxes with red x if you right click o them it has the pop up blocker, i just took it off and hyperlinks work now.. i have no idea why.. i  know nothing about computers, an di guess comcast doesn't either. 

New Poster

Re: Comcast mail hyperlinks

Thank you. Turning off my Chrome pop-up blocker worked for me too. I don't understand why the pop-up blocker was even on. I hadn't changed it one way or another. Anyway, thanks for the fix!

New Poster

Re: Comcast mail hyperlinks

You're welcome.  Happy President's Day!

Frequent Visitor

Re: links in email no longer opening

I am having the same problem.  Just started recently.

Regular Visitor

Re: links in email no longer opening


@jethorse wrote:

look in your browser window at the top, its not a "dot"  now that i look.. its a square with a red x in it.. it is a popup blocker..  maybe yours looks a little different.. ive got window seven still.. but somplace on there , there is a popup blocker choice.. see if you can find it.. ? 


Bingo!! It worked for me. Make sure you are in your Xfinity emails to see it in . Thanks

New Poster

Re: links in email no longer opening

Yes. This did work.
I was close to maybe having to call a computer geek company as was really an annoying issue and I’m not at all computerized a bit so a big thank you to all those who responded and I learned that it’s called a hyperlink inside of the email I didn’t even know that I just called it a link !
Thanks all who helped!!
New Poster

Re: links in email no longer opening

Issue:

Links don’t seem to work on Xfinity websites.  They aren’t opening websites as expected.

 

Cause:

According to the Google Chromium forums, this was a known bug in Google Chrome 71 (January release) that didn’t get resolved in Google Chrome 72 (February release).  The bug considers all links that open a new tab to be “pop-ups,” therefore falling under the jurisdiction of Chrome’s built-in pop-up blocker.

 

This reportedly includes:

  • Links that include target=”_blank”, which ask the browser to open the link in a new tab instead of in the current tab.
  • Links that the user opened with the “open link in new tab” action.  For example, right-clicking the link and selecting “open link in new tab” or by pressing the CTRL key while left-clicking the link).

 

Some experts are blaming the issue on Chrome extensions that scan the link before opening it, for example Ghostery and Norton Security Online.

 

Resolution:

 

Until Google Chrome fixes the bug, users can “allow” Xfinity websites to open links in new tabs.

 

The easiest method is to:

  1. Click on a link that doesn’t seem to open.
  2. This will display a small red alert that says “Pop-up blocked” on the far-right of Chrome’s address bar, to the right of the website address.  This alert will shrink and go away in about 3-seconds, leaving only a small red “X” icon.
  3. Click on this icon and select “Always allow pop-ups and redirects from…” then click the “Done” button.
  4. That website will now be allowed to open links in new tabs.
  5. If you experience this issue on other websites, please repeat the steps above on that website as well.
New Poster

Re: links in email no longer opening

Try turning off the pop up blocker in Chrome for the xfinity site. (Settings...Advanced...Privacy...Content.) This worked for me.

New Poster

Re: Comcast mail hyperlinks

turning off pop-up blocker worked for me too. thanks!

New Poster

Re: links in email no longer opening

I wasted over an hour on the phone with "support" yesterday on this issue. I'm sorry, but using another browser or restarting xfinity everytime I check email is nonsense. This is obviously an issue on their end that they can not, or do not, want to fix. Disappointed.

New Poster

Re: links in email no longer opening

Reset did nothing

Expert

Re: links in email no longer opening


@Jbartonp wrote:

I wasted over an hour on the phone with "support" yesterday on this issue. I'm sorry, but using another browser or restarting xfinity everytime I check email is nonsense. This is obviously an issue on their end that they can not, or do not, want to fix. Disappointed.


Check out this message and see if the solution works for you.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: links in email no longer opening

As of a day or 2 ago, I am having the same problem! Not one hyperlink in my Comcast (only, as I have gmail accounts) emails will work. Since I use my Chromebook all the time, there is NO other browser. How is this not a Comcast problem?

New Poster

Re: Comcast mail hyperlinks

Yes, turning off my pop-up blocker also fixed my problem with Comcast email hyperlinks not working.  But, this is NOT the preferred way to work; it was working for more than 2.5 years and all of a sudden didn't. ??? I prefer to have the blocker on.

Regular Visitor

Re: links in email no longer opening

Try right clicking the hyperlinc, and open in new tab. That seems to be a temporary solution.

New Poster

Re: Comcast mail hyperlinks

Had the same problem.  Removed Comcast from list of blocked pop up sites and it also worked.

Regular Visitor

Re: Comcast mail hyperlinks

Thanks Jeff. I added connect.xfinity.com to allow popups setting in Chrome, and now links work. That way, I can leave pop up blocker on for everything else that I want blocked.

New Poster

Re: links in email no longer opening

Open the email then right click on the link.  A dialogue box will open and you will have a choice that says "Open link in new tab."  A little more complicated but it works.