Community Forum

Subtitles on Amazon prime not working

This board is for questions about accessibility features (Video Description, Closed Captioning, Video guidance, etc.) for people with disabilities.
Frequent Visitor

Subtitles on Amazon prime not working

I had started an earlier thread under the subject of closed caption not working in Amazon video. I was informed it should have read subtitles so I have started a new thread. I thought I had corrected this issue by doing a refresh and unplugging my box for 5 min but it has returned again today.  I tried unplugging the box but this time no luck so I am back to square 1. I have not done a fresh but evenif that works I can’t be doing this every day I watch Amazon. Any other ideas out there?

Expert

Re: Subtitles on Amazon prime not working


@Tlev55 wrote:

I had started an earlier thread under the subject of closed caption not working in Amazon video. I was informed it should have read subtitles so I have started a new thread. I thought I had corrected this issue by doing a refresh and unplugging my box for 5 min but it has returned again today.  I tried unplugging the box but this time no luck so I am back to square 1. I have not done a fresh but evenif that works I can’t be doing this every day I watch Amazon. Any other ideas out there?


subtitles are on many titles (stream and DVD) that work like captions (used for broadcast video). The X1 Amazon Video app allows you to search for a title and upon selecting a result, are offered subtitles (if available). you select the subtitle menu before playing the video.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Subtitles on Amazon prime not working

Once again I’m surprised I’m the only one having this issue but I have at least found a work around. When I go into Amazon video the “subtitles” are missing. I confirm in the subtitles menu along the top that it is selected and then I start the show and hit the down arrow on the remote. I then arrow over to the CC logo at the bottom right and select it. It pauses the show and gives me options to turn subtitles on or off and also font size. Sometimes turning subtitles off and back on works and sometimes changing font size works. May take a couple tries but eventually I can get subtitles. It works fine until the next day and I repeat the process. Shouldn’t have to do this but maybe Comcast will have a fix later.  Feel free to close this thread.