user_db5261's profile

New Poster

 • 

2 Messages

Mon, Jan 10, 2022 3:18 PM

Extremely Slow Phone App Loading When Connected to xFi Gateway

Takes a long time to load apps on my android phone. Usually times out.  Including the xFi app.  If I turn the wifi off on my phone problem goes away. If I connect to a different wifi, problem goes away.

I tried reinstalling apps and restarting phone.  Tried restarting router.  Does not fix.

My laptop and my family iPhones has no issues. 

This is extremely annoying.

 

Official Employee

 • 

288 Messages

7 m ago

Hello there @user_db5261 [Edited username] ! Thank you so much for reaching out to us on the Community Forums for the trouble you are having with the android phone. While looking over the full experience this device and other devices on the network are having the first thing that comes to mind is does the android phone connect to the 2.4 GHz network or the 5 GHz network. If it's on the 2.4 that may be causing a slower speed which makes the app time out. Connecting to a different network would change that experience.

I'm going to ask a few questions to help narrow down possible causes as well. Are you able to see which network the android phone is connecting to? Have you had an issues with websites on the same device? Are you able to run a speed test? Do you use a VPN on this device? Has the device been rooted? If I may, what type of android is having the issue? Is the device updated?  

(edited)

Visitor

 • 

1 Message

6 m ago

Has there been a solution to this. I'm experiencing the same issues. Ironically this happened after I received a text from xfinity saying they were doing construction in my area to "improve" the network.

Official Employee

 • 

3.2K Messages

Greetings, @XficustomerKay! Thanks for reaching out to us on the Forums! I hope you are having an amazing day! I apologize to hear that you are having issues with the xfi app loading as well. Are you only have issues with this app when connected to your network or does it take some time for other apps to load as well?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
rick24

Contributor

 • 

14 Messages

5 m ago

I am having the same issue on my iphone.  When I connect to every other wifi network, everything loads fine.  When I'm home connecting to my xfinity wifi, there seems to be a 30-60 second delay in obtaining anything over the internet.  When the data finally loads I'm fine for browsing.  Then after a little bit while it's idle, it happens all over again.  This just started recently.

rick24

Contributor

 • 

14 Messages

5 m ago

Hello, Have you heard anymore on this?  I'm having the same issue at home.  Thanks.

XfinityKorie

Official Employee

 • 

783 Messages

Hey there, @rick24. Does this happen with any other iPhone in the home or apple products? What troubleshooting have you tried? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
rick24

Contributor

 • 

14 Messages

Happens to numerous phones.  Rebooted router and phones

Visitor

 • 

1 Message

5 m ago

I've been having this issue for a couple of months and it is INSANELY annoying. EVERY media related app, Hulu, Netflix, Disney, Amazon Music and Video... specifically have issues like this. If i disconnect and use cell signal everything is instant! Imagine a media broadcast company like Comcast/Xfinity throttling competitors. Any time one of these apps has to authenticate it takes minutes to continue. I literally have to disconnect from my home internet authenticate then reconnect every time.

New Poster

 • 

4 Messages

4 m ago

I am having the same issue as well.  This only happens with android devices.  When will Xfinity address the issue as it is apparently wide spread.  I have been having this issue since the major outage that happened a few months ago.  If this issue is not addressed, I am going to have to start looking at a different provider.

Official Employee

 • 

405 Messages

Hi @user_Jcb012 [Edited username]

Thank you for letting us know the issues you are experiencing with the slow loading of apps. I know this must be an extremely frustrating situation.

 

What troubleshooting has already been attempted? I will do my best to avoid repeating the same steps for you! 

(edited)

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New Poster

 • 

4 Messages

The same troubleshooting everyone else has been doing.  The issue appears to affect only android devices.  I disconnect my wifi and everything connects as expected.  I even connect to other wifi networks and everything connects as expected.  When I connect back to my wifi the issue is present again 

Official Employee

 • 

282 Messages

I am sorry to hear you are having issues with only android devices. Have you tried to reset the modem already? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New Poster

 • 

4 Messages

Yes multiple times.  I even disabled advanced security but there is no difference.

Official Employee

 • 

282 Messages

I am happy to look into your service and see what I can do remotely for you.

 

Could you please send our team a direct message with your full name and full address? Our team can most definitely take a further look at this issue. To send a "Peer to peer" ("Private") message:

Click "Sign In" if necessary

  • Click the "Peer to peer chat" icon
  • Click the "New message" (pencil and paper) icon
  • Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list which appears. The "Xfinity Support" graphic replaces the "To:" line
  • Type your message in the text area near the bottom of the window
  • Press Enter to send it
I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

10 Messages

4 m ago

We are experiencing very similar issues to the others here. Android devices not loading apps or online content while on Xfinity wifi. Going off the wifi, all works fine. This happened with an old Galaxy S7 and a brand new S22.

We have Xfi pods, so I believe I am unable to check on if we are on 2.4ghz or 5ghz, correct? What can be done here?

Official Employee

 • 

277 Messages

Hi, @Cmwill88.

 

Please create your own post and I will be happy to assist you with the wifi issues you are experiencing. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

10 Messages

@XfinityOtto Made a new post here: https://forums.xfinity.com/conversations/your-home-network/phones-having-extremely-slow-connections-while-on-wifi/6259f167ee0ef23e52624b35

Official Employee

 • 

561 Messages

Thank you for doing that for me! If you don't mind, can I get you to send me a modmail to this link, https://comca.st/3MtuNRF, with your name and address, we are happy to take a look at what might be going on! u/

Cmwill88, we are here 24/7 so message us anytime!

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

4 m ago

Having the same issues. This is super annoying.

XfinityJorge

Official Employee

 • 

400 Messages

Hello there @Sielove thanks for contacting our Xfinity Support Team. You came to the right place for help and we are here to work together. In order to get started, can you please send me a private message to Xfinity Support with your full name and full address by clicking the chat icon in the top right?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

3 m ago

having the same issue as everyone else.  when on home wifi network everything is super slow.  Off wifi, ir any other wifi network everything is fine.

Official Employee

 • 

387 Messages

Greetings, @jennifersnet. Thank you for taking the time to reach out to us. If possible, could you please create your own post in regard to the issues that you're experiencing so that we can ensure that this is looked into further? Please include as many details as possible in regard to the issue that you've encountered so that we can get this taken care of as soon as possible. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

2 m ago

I am having this same issue. I can connect to the wifi but when I go to load instagram, disney +, etc. It just won't load while connect my to xfi. The wifi works great with the smart TV and desktop. Just for some reason there is an issue with streaming apps on my phone. The phone works great and apps as well when disconnected from wifi or connected to a different wifi. Do i need a new modem?

Official Employee

 • 

633 Messages

Welcome to our community forum, @user_21dbec! I love using streaming apps on my phone so I'd be frustrated if they weren't working. Have you tried uninstalling and reinstalling the apps? Have you tried forgetting the network and reconnecting?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

2 m ago

I am having the same issue. Random apps on my adroid phone (weather undeground etc) are not loading when on the xfi wifi. They are loading fine on the carrier data network. I restarted the router, phone, checked for app updates etc. Other devices (roku tv, chromebooks, ios phone) work ok. 

XfinityDevin

Official Employee

 • 

720 Messages

@user_9d562e

Good morning! Thank you for letting us know all you have tried with troubleshooting so far. Those are great steps to help narrow down the concern and so that we don’t ask you to repeat anything. This is something we definitely want to resolve for you so you can use your wireless connection with us on your phone.

Are you connected with X-Fi Pods or just the gateway? Aside from apps, can you load websites and surf the web without issue?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

4 Messages

I am sitting literally a foot away from the XFi gateway and am having the same issue.  I turned off the wifi and my apps that were not loading, started loading.  Possible bug in XFi?

Visitor

 • 

3 Messages

2 m ago

Having the same issue when I am in home  and connected to wifi network everything is super slow and will time out/not download. Sometimes I have to just turn off wifi and use cell signal to get pictures, stories / videos to load. Usually on any other wifi network everything is fine. 

Official Employee

 • 

290 Messages

 

 

 

Thank you for reaching out to us due to the issues you're having with your internet. It would be my pleasure to assist you with getting to the bottom of what is going on. We're Xfinity experts and here to help. I do want to be sure that we're not having you duplicate any troubleshooting unless necessary. What steps have you tried so far? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

3 Messages

restarting phone/ modem uninstalling app etc. 

Official Employee

 • 

207 Messages

Do you happen to notice this happening on more than one device? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

2 m ago

Having the same issue.  Weather Channel, MLB Play, COVID Symptom Tracker to name a few.  Why don't you post a fix rather than telling everyone to contract you?

Official Employee

 • 

310 Messages

Hey there, @user_043648

Thank You for taking the time to post to this thread, here on the Community Forum. The main reason that we invite people to Direct Messaging is so that we can look at the account, and complete account specific troubleshooting.

I totally understand that the symptom - slow phone apps When Connected to an xFi Gateway, can all seem the same, but there are a lot of potential causes. 

With that said, I am happy to work with you, right here, to see if we can find a solution that helps you and others.

What model Xfinity Gateway do you have?

What speed tier are you subscribed to?

How many devices are connected to the Xfinity Gateway when the issue occurs?

What make and modem phone are we using?

Thanks! 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

7 Messages

2 m ago

Has there been any resolution on this issue? I have been having this same problem for over a month. Restarted the gateway, replaced the gateway, replaced the xfi pods, and even had a tech check the connections. Works fine on computers & TV's, only seams to effects my android phones and tablets. Apps like "The weather channel", "Disney Plus" and the worst is all the Xfinity apps.

XfinityKorie

Official Employee

 • 

783 Messages

I am sorry for the continued issues! We do appreciate you for taking the steps you have to get this resolved. When connected to the internet, are you doing so via the pods or modem? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

7 Messages

Both the pod and the modem. It doesn't matter which one, it happens on both.

Official Employee

 • 

482 Messages

Have you tried deleting the apps then downloading them again? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

7 Messages

Yes I have and it didn't fix the issue.

Official Employee

 • 

482 Messages

What are your download speeds when you are having the long load times?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

1 m ago

I'm also having this issue for more than a month. I have a droid device. Latest OS. Tried rebooting router. Tried reloading apps. Occurs in multiple apps including the Xfinity app. If I turn off WiFi, poof, the problem goes away, so it is definitely something in the Xfinity wifi.

Official Employee

 • 

243 Messages

Hi @user_0a8a89. Xfinity Wi-Fi is public and the internet speeds are slower than in home private speeds. They also may be overcrowded with other users and this will also slow the speeds down.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here