Airchamby's profile

Regular Visitor

 • 

1 Message

Fri, Apr 3, 2020 2:00 AM

Prime Video App Won't Launch

If I press the Xfinity button on my remote and go to Apps and click on the Prime Video App it launches and you get a blue screen with the Prime Video logo and 3 white dots on the bottom.  After a couple of minutes the 3 dots go away but the blue screen stays and does not go away.  If I press Exit and get out of it and then press the Xfinity button and go to Settings then Help then Reset, my cable box resets.  I can then go back to Apps and press the Prime Video button and it loads normally.  But the next day when I turn on my tv and try to load Prime Video I have the same problem and have to reset the cable box again.

I am an Amazon Prime member and when I can get it to load it works just fine.

I do not have this problem with any other apps such as Netflix or Youtube.

I do not have this problem with any of the other 2 tvs in my home.

I have reset my cable box, got into my Prime Video app, and logged out of this device and logged back in but I continue to have the same problem.

There is button in Xfinity/Settings/Help named Reset Netflix.  Is there a way to Reset Prime Video?  Is there a way to uninstall the Prime Video app on my cable box and re-install it?

Responses

New Poster

 • 

2 Messages

1 y ago

I have the same issue apparently

 

New Poster

 • 

1 Message

1 y ago

I can’t get the app to launch either!

New Poster

 • 

1 Message

1 y ago

Did you ever figure this out? I have the same issue and cant find anything to solve the issue. 

hbirenbaum

Frequent Visitor

 • 

12 Messages

1 y ago

I have the same issue. I can launch Prime Video directly from my smart TV's app using the Samsung remotr, but can't when I use Xfinity's box and remote. Don't want to use two remotes. No problem with Netflix or other internet streaming apps through Xfinity. What gives? Why do I have to reboot the box and wait, wait, wait to see if it will work?
hbirenbaum

Frequent Visitor

 • 

12 Messages

1 y ago

Thanks, but I am a Prime member and am linked to the App. This just started about 2-3 weeks ago. The App starts up and says Prime Video and the 3 dots below indicates that it is loading, but it never connects. Rebooting the box sometimes works. But shouldn't have to do this every time I want to watch.

Howard

Regular Visitor

 • 

1 Message

1 y ago

Same problem here. I wish someone would answer with a fix.

New Poster

 • 

1 Message

1 y ago

Same problem here.  When I called Xfinity about it they sent a new box.  But it's still doing it.  

 

HeyDaddy

Contributor

 • 

78 Messages

1 y ago

Same problem here.  

New Poster

 • 

1 Message

1 y ago

Yeah I'm having the same exact problem except my Netflix and Hulu won't work either. On Netflix and Hulu and can log in and pick what I want to watch but as soon as it starts to load it gives an error. Same with Amazon prime video, if it actually gets past the main loading screen then I can find what I want to watch and when it goes to load the video it gives an error. It's very frustrating. Peacock is the only thing I can get to work which by the way works perfectly. Of course it does though because Comcast owns NBC and they are the ones that released peacock.
hbirenbaum

Frequent Visitor

 • 

12 Messages

1 y ago

It's been frustrating.

New Poster

 • 

4 Messages

1 y ago

I’ve done all that. Still won’t load. Talked to xfinity, they suggested unplugging to reboot. Works for that day. Have to reboot everyday to watch amazon prime. They send me a new box. Same issue. Someone needs to fix this.

Visitor

 • 

1 Message

3 m ago

I want to unregister on Prime Video and then re-register using my Prime Video account.  Right now it wants me to purchase a new account.  When I click on the Prime Video app it automatically takes me to the incorrect account.

Official Employee

 • 

204 Messages

Hello, @user_2d70d8, thank you for reaching out in our forum for help with your X1 App issue with your Prime account. I stream a ton, so I definitely get where you're coming from, so let's roll up our sleeves and get you taken care of. In order to get started can you please send me a private message to Xfinity Support with your full name and full address by clicking the chat icon in the top right?

Visitor

 • 

1 Message

3 m ago

New Xfinity customer just plugged in the Flex and signing into everything. All is working except the Amazon Prime Video. Click to sign in and just a dark screen with a circle that spins and spins, never getting past it. I unplugged the unit to see if that would fix it and it still will not load. Thanks for looking into this issue.

Official Employee

 • 

93 Messages

Hi, thank you for reaching out to our Xfinity Forums. I understand you are having issues with Amazon Prime Video App. Are you able to access the app from a different device? 

Visitor

 • 

1 Message

1 m ago

Same issue as everyone else. Every other app works except the Prime Video app. The Prime Video app works just fine on my other devices.

(edited)

Official Employee

 • 

165 Messages

Hey @PaleHorse33. Thank you for letting us know you are running into issues on your cable box with Amazing Prime Video. We would love to help get this working for you. Can you please send us a private message here so we can help out further with troubleshooting? We can also check to see if we need to open up a ticket for this issue or not. Just hit the chat icon in the top right-hand corner of the screen, click "new message", type "Xfinity Support" and select that profile to message us so we can assist you while keeping your information safe!

Edit: We will no longer be monitoring this post due to age. If anyone has continued issues with this, we do ask that you please create your own new thread and we'll be able to help out there!

(edited)

New to the Community?

Start Here