jwmccnn's profile

Contributor

 • 

246 Messages

Thursday, November 23rd, 2023 11:15 PM

Malfunctioning Xi-6 box

One of my Xi-6 Set top Boxes keeps losing connection.  I would like another sent to me so I can replace the one not functioning properly.

Official Employee

 • 

703 Messages

3 months ago

@jwmccnn Hello, we definitely want to ensure that your box is working properly! You can easily go in store to swap out your equipment at any time, or we can ship you out a device for up to $15. However, often times the equipment itself is not the issue. You mentioned that you have an Xi6 TV box, which is one of our wireless boxes. If it is loosing connection, it may point to either your main TV box having an issue, or your WiFi having an issue since it uses your WiFi to connect to your main TV box for its connection. How is your internet working at home? Is your modem online and your devices are able to connect to WiFi without issue? Have you run into any connection issues with your main TV box?

Contributor

 • 

246 Messages

3 months ago

@XfinityKatie

First, the Xi-6 box is not available in any store.  I had to order the ones I have 11 months ago. 

The internet is working fine, all other devices are fine.  This particular Xi-6 box is sitting right next to the modem and has worked fine for 10.5 months.  There is no "Main TV Box" when you have wireless Xi-6 boxes, everything is online and you should know that.

Also, why should I have to pay $15 for you to ship me a replacement STB when it is YOUR equipment that is not functioning correctly?

I would like you to replace this box free of charge to me.

(edited)

Official Employee

 • 

703 Messages

@jwmccnn You are correct on the Xi6 boxes not being available in store, my apologies for that mix up! Our wireless boxes are only available via shipment, thank you for keeping me honestly! In order to use an Xi5 or Xi6 wireless box, it does require an XG1 or XG2 TV Box on the account. You may be able to get away without using an XG1 or XG2 TV in certain areas, but in almost all locations a main XG1 or XG2 TV box is required, which is what I was referencing. I am glad to hear that the other devices in the home are working well for you! If the equipment is the issue, we should be able to replace it for you free of charge. However, we would first have to do some troubleshooting together to rule out other possibilities. Are you getting any error messages on screen when you loose connection? Are you loosing connection no matter what you are doing (watching live TV, On Demand, using an App, etc.)? If possible, are you able to send a screenshot of what you see on screen when the device looses connection? We'll ensure we get this figured out for you!

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Contributor

 • 

246 Messages

@XfinityKatie​ the disconnect issue is happening no matter what is being watched. 99% of what is watched on this particular box is your Comcast program lineup. When this box disconnects, all the other equipment continues to function as usual. Attached is a pic of the error message, disconnecting the power on the box and letting the box reset will make the box function normally. Until it happens again. On Sunday afternoon, while trying to watch NFL football it has happened 4 times.

(edited)

Official Employee

 • 

807 Messages

Thank you for providing this information to us. Have you attempted to change the HDMI cable on the box? Sometimes even if a little loose it can make the connection message pop up as well. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Contributor

 • 

246 Messages

@XfinityJanelle​ Have tried that, yes. The problem still happens.  All other equipment functions fine.  At this point, I need a new Xi-6 sent to me.

Official Employee

 • 

807 Messages

Let's get working on this for you! Could you please send our team a direct message with your full name and full address? Our team can most definitely take a further look at this issue.

To send a "Direct Message":
Click "Sign In" if necessary
• Click the "Direct Message chat" icon
• Click the "New message" (pencil and paper) icon
• Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list which appears. The "Xfinity Support" graphic replaces the "To:" line
• Type your message in the text area near the bottom of the window
• Press Enter to send it

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Official Employee

 • 

703 Messages

2 months ago

Thank you for working with our team @jwmccnn so we could get you set up with a new box. I am glad the replacement was able to resolve the issue you were seeing! If you ever need anything else, just make a new post and our team will be available to you here to help! 

forum icon

New to the Community?

Start Here