multi007's profile

New Poster

 • 

4 Messages

Sat, Sep 18, 2021 11:11 PM

ALL OF MY TiVo roamios are missing channel 1620- HELP!!

I have 4 TiVo  roamios.  All of them do not show channel 1620 (great American country HD)   I e called customer service and was told my tivos are old technology and to get x1.    I’d rather cancel. Also she did not seem to know about tivos. So I’m just going to ignore her , and ask for help here.    CAN SOMEONE PLEASE HELP !   I need someone who knows about tivos and cable cards to authorize ALL FOUR tivos to show channel 1620.   

Official Employee

 • 

241 Messages

3 m ago

Thank you for taking the time to reach out and being part of the Xfinity family. I'm so sorry you're having issues accessing channel 1620. I'd be happy to help you find out what's going on. In order to get started can you please send me a private message to Xfinity Support with your full name and full address by clicking the chat icon in the top right?

wbguy99

Visitor

 • 

11 Messages

2 m ago

I have the same issue.   I called in to the cable card department and it seems, they don't know what is going on.   They have sent signal after signal.  The person I talked to didn't even know about the channels that are IP channels.  As I asked if 1620 was going to be an IP channel like Hallmark Drama.  He ran a couple more refreshes and is sending a tech out.   I am wondering if it is just with Roamio's or if people with Edge's are having issues also.  

New to the Community?

Start Here