Community Forum

Remote Control

Highlighted
New Poster

Remote Control

My Xfinity remote control stopped working today. I changed the batteries and it still does not work -- cannot change channels or access thr TV guide   

Highlighted
Contributor

Re: Remote Control

Can you try rebooting your box and see if that solves it?
Highlighted
New Poster

Re: remote not working properly

@Rustyben  @CCAndrew  @nanstewart2002 

 

I just started having a similar problem with my remote this morning.  Controls the TV on/off just fine, but won't communicate with the box.  I changed the batteries, rebooted the box, and nothing works.  The LED indicator turns from green to red when I push any buttons other than "TV".  Is there a fix for this?  I'm not sure why it would still communicate with my TV and not the cable box?

Highlighted
New Poster

Re: Remote Control

@Topnotch8797 

 

Did you ever resolve this issue with the remote?  I'm having the same problem.  Changing batteries didn't work, neither did resetting the box.  It works for the TV on/off, but the LED turns from green to red when any other buttons are pushed.

Highlighted
Expert

Re: Remote Control


@asasasasasasasa wrote:

@Topnotch8797 

 

Did you ever resolve this issue with the remote?  I'm having the same problem.  Changing batteries didn't work, neither did resetting the box.  It works for the TV on/off, but the LED turns from green to red when any other buttons are pushed.


the green/red means the box needs to be rebooted (after a firmware update). the profile for your RF paired remote did not properly load on that set top box restart.

edit: combined your cross-posts.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!