Community Forum

Distorted signal between set-top box and TV

New Poster

Distorted signal between set-top box and TV

About 6 months ago we bought a TCL 4k smart tv.  We were still using our old MOTO DCX3400 (?) DVR (no X1).  The TCL is a Roku TV so has its own home screen.  One icon/tile is for the DVR which is just a labeled HDMI input.  About 3 weeks ago, while watching live tv or a recording, the screen would start getting 'snow' and within seconds the entire screen was nothing but static.  We were planning an update to X1 so didn't worry about it.  A week ago, we made the leap and are running an X1 set top box.  Same exact issue.  We've since discovered that pressing the home button on the TV remote to get back to its own 'home' screen and going straight back into the DVR would completely clear the static.  Obviously an issue with the signal between the set top box and the TV.  Perhaps it's an issue with the TV since it happened with both set top boxes.  But, figured I'd start here to see if there's a signal strength issue or something related.  Thanks in advance.

Diamond Problem Solver

Re: Distorted signal between set-top box and TV

Change the hdmi cord and see what happens. But right now the tv is the common denominator. Have you tried different inputs or a different device in that slot to see if it replicates or not?

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Silver Problem Solver

Re: Distorted signal between set-top box and TV


@CASchryver wrote:

About 6 months ago we bought a TCL 4k smart tv.  We were still using our old MOTO DCX3400 (?) DVR (no X1).  The TCL is a Roku TV so has its own home screen.  One icon/tile is for the DVR which is just a labeled HDMI input.  About 3 weeks ago, while watching live tv or a recording, the screen would start getting 'snow' and within seconds the entire screen was nothing but static.  We were planning an update to X1 so didn't worry about it.  A week ago, we made the leap and are running an X1 set top box.  Same exact issue.  We've since discovered that pressing the home button on the TV remote to get back to its own 'home' screen and going straight back into the DVR would completely clear the static.  Obviously an issue with the signal between the set top box and the TV.  Perhaps it's an issue with the TV since it happened with both set top boxes.  But, figured I'd start here to see if there's a signal strength issue or something related.  Thanks in advance.


If the TV has more than one HDMI port, try them all.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Distorted signal between set-top box and TV - RESOLVED

Just a quick update.  I replaced the HDMI cable and haven't had the problem again since.  Hopefully this is the long term solution.  Thanks for the suggestions.