Community Forum

Could removal of an Comcast amplifier cause this?

Highlighted
New Poster

Could removal of an Comcast amplifier cause this?

I recently had a visit from a Comcast technician.  My larger cable box was giving an error code when trying to access OnDemand and Caller ID on the TV stopped working.  Comcast could not contact the box to reset it.  Everything else on the box and the other services I have (router, phone, 2 small TV boxes) worked correctly.

 

The technician (who was great) removed the Comcast 5-way splitter that brought the signal into the house and changed it to a 3-way splitter.  He also removed an amplifier that was there as well (he asked me if that was okay since he didn’t see the need for it). 

 

OnDemand works now.  Caller ID on the TV still doesn’t work (it is turned on).  Some channels look a little more pixelated than before.  Closed Captioning worked perfectly before but now on some stations it stutters (the word “something” might look like somsomeththing, for instance). 

 

Does this sound like a problem that could be corrected by having Comcast replace the amplifier?  Or does this sound like another issue? 

 

Thank you.

Highlighted
Diamond Problem Solver

Re: Could removal of an Comcast amplifier cause this?

Depends on the type of amplifier it was. Some actually amplify, the correct one to use with X1 doesn’t amplify but replace the splitter to negate loss of signal. Comcast doesn’t use 5 way splitters, so not sure about that. Best would be having another tech out. The pic is the proper amplifier a tech would use for X1 boxes

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
6E56ECE8-4CCB-44C6-BAD2-E1F59EC5B9F0.jpeg