Community Forum

For The Past Year, Closed Captioning Stops Working Even Though The CC Option Is Still Showing "On"

This board is for questions about accessibility features (Video Description, Closed Captioning, Video guidance, etc.) for people with disabilities.
Highlighted
Contributor

For The Past Year, Closed Captioning Stops Working Even Though The CC Option Is Still Showing "On"

The closed-captioning on the X1 box fails to consistently stay working even though it is physically showing as "ON" in the settings menu.

 

The ONLY way I know of that will temporarily fix this problem is to go back into the settings menu and turn the closed-captioning back OFF and then turn the closed-captioning back ON.

 

Now the closed-captioning may stay working for a few hours or a day but then it will seemingly randomly stops working again.

 

It seems to be a glitch that others have been experiencing for quite some time as well.

 

Will someone at Comcast please address and fix this known ongoing closed-captioning issue?

 

Thank You.

Highlighted
Expert

Re: For The Past Year, Closed Captioning Stops Working Even Though The CC Option Is Still Showing &q


@AudioDropper wrote:

The closed-captioning on the X1 box fails to consistently stay working even though it is physically showing as "ON" in the settings menu.

 

The ONLY way I know of that will temporarily fix this problem is to go back into the settings menu and turn the closed-captioning back OFF and then turn the closed-captioning back ON.

 

Now the closed-captioning may stay working for a few hours or a day but then it will seemingly randomly stops working again.

 

It seems to be a glitch that others have been experiencing for quite some time as well.

 

Will someone at Comcast please address and fix this known ongoing closed-captioning issue?

 

Thank You.


that is the nature of the digital version of closed captions. you can use voice remote to say 'captions' instead of all the button presses (toggles on/off).



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Contributor

Re: For The Past Year, Closed Captioning Stops Working Even Though The CC Option Is Still Showing &a

I don't experience this issue with closed-captioning on any other "digital" adaptors or the Xfinity Stream App or Stream Website.

 

And I never had this closed-captioning problem before with other Comcast equipment that was considered "digital" equipment.

 

On any other devices/equipment, if the closed-captioning was showing as "ON" it 99.9% of the time actually worked and STAYED ON and continuously WORKING.

 

Now, you are saying because it's "digital" I have to turn it off and back on every time it decides to stop working and I want it to work?

Highlighted
Expert

Re: For The Past Year, Closed Captioning Stops Working Even Though The CC Option Is Still Showing &a


@AudioDropper wrote:

I don't experience this issue with closed-captioning on any other "digital" adaptors or the Xfinity Stream App or Stream Website.

 

And I never had this closed-captioning problem before with other Comcast equipment that was considered "digital" equipment.

 

On any other devices/equipment, if the closed-captioning was showing as "ON" it 99.9% of the time actually worked and STAYED ON and continuously WORKING.

 

Now, you are saying because it's "digital" I have to turn it off and back on every time it decides to stop working and I want it to work?


it is a stream and as such must be synchronized with the video. it happens. the test is when you have the problem is try a smart phone device on same program and location in the program and see if it is working there. if so, then your X1 set top box may be low signal/high noise level.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Contributor

Re: For The Past Year, Closed Captioning Stops Working Even Though The CC Option Is Still Showing &a

I understand what you are saying.

 

The same shows, whether they are on linear tv, live tv, or On Demand, have the disappearing closed-captioning issues.  These are all shows that truly have closed-captioning, but it seems as though maybe when the X1 box is turned off and/or goes to sleep and/or into a power save mode the closed captioning stops working unless I manually turn it OFF and then back ON in the settings menu...then it will work for awhile.

 

And I can have the same exact show playing at the same exact time on other devices such as on: a digital adapter; or a computer on the Xfinity Stream website; or a smartphone with the Xfinity Stream app and those devices all have the closed-captioning working.

 

I've had signal levels tested in and outside the home by a technician at the home who said the levels are within range so it may not be that, but who knows.

 

Thanks for the ideas and trying to help.

Highlighted
Contributor

Re: For The Past Year, Closed Captioning Stops Working Even Though The CC Option Is Still Showing &a

@ComcastCesar was able to get this issue for me resolved but it has reappeared again for me.  In July, I was told my X1 box firmware was updated to fix the issue.  The closed-captioning is back to not working consistently and staying on.   It's not an issue of the program not having any closed-captioning.  The actual closed-captioning option is toggled ON, but the only way to temporarily fix it, that I know of, is to manually turn it off and turn it back on again.  I have to do this anytime I want the closed-captioning to work.  And this issue happens whether I'm watching On-Demand or live/linear tv programs.

Highlighted
New Poster

Re: For The Past Year, Closed Captioning Stops Working Even Though The CC Option Is Still Showing &a

Been happening for about a month or so with me too. Unfortunately Xfinity has a monopoly in my city (literally!) otherwise I'd be all over FIOS again