U

Visitor

 • 

3 Messages

Sunday, June 4th, 2023 4:46 PM

Closed

Next to no wifi range.

I've recently set up xFi Gateway (XB6). I've plugged a coaxial cable into it and it technically "works", but there's almost zero wifi range. My phone has to be touching the router to even get a signal. The moment I walk just a few feet away, the signal drops completely. There are no electronics turned on since I've just moved in so there shouldn't be any interference. I've made sure the router is in an elevated spot, ran multiple tests using the app, and power cycled to no avail. What are my options?

Accepted Solution

Contributor

 • 

72 Messages

1 year ago

Sounds like a bad router to me. Had you used the XB6 before this without a problem? (Could it have gotten damaged in a move?) Unless you have this sitting in a metal box like a filing cabinet, you should get at least 30-40 foot of good signals. It almost sounds like the antenna(s) got disconnected internally.

Visitor

 • 

3 Messages

@NoGoodNamesLeft4Me​ I picked it up from my local Xfinity Store and immediately placed it high atop a closet shelf since I was doing renovations at the time. I have not dropped it or damaged it in anyway as far as I know. I received it Mid-May and only set it up about last week after renovations were finished. Can I just go to my Xfinity store and ask for a replacement?

(edited)

Contributor

 • 

72 Messages

I'm not that familiar with Xfinity-branded routers. It sounds like you have the Xfinity xFi XB6 (Arris TG3482G). https://approvedmodems.org/xfinity-xfi-xb6-review/ and https://www.xfinity.com/support/articles/broadband-gateways-userguides had some info. I'm surprised that you could still get that version, actually. I would expect you would get the XB8 if you just got it in May 2023. I think I would try to exchange it myself. It's old, but I doubt that a 2 foot wireless range is a "feature" of that model.

Official Employee

 • 

1.9K Messages

1 year ago

Hi there! Our awesome digital care team would be happy to assist you. Can you initiate a direct message and start with your full name and address? To start a message, you must be signed in. Please click the envelope icon in the top right of the page next to the bell, and send your message to "Xfinity Support". Talk to you there!

Official Employee

 • 

1.4K Messages

1 year ago

@user_7b209c  Hi! Was the gateway swapped? Is it working better?

Visitor

 • 

3 Messages

@XfinityEthan​ Yes! The gateway was swapped. Everything works as it should now.

Problem Solver

 • 

393 Messages

@user_7b209c Excellent. That is what we love to hear! Please know that we are always here to assist at the Xfinity Community Forums in the future.

I no longer work for Comcast.

forum icon

New to the Community?

Start Here