U

Friday, October 20th, 2023 11:23 AM

Stream not connecting

Streaming is working from the TV box but it will not connect from my PC it is stuck on the "Now connecting to your entertainment experience" screen I have restarted the complete network and tried connecting from multiple PC's.  No VPN to interrupt and still no luck.

How do you troubleshoot this issue?

Visitor

 • 

3 Messages

5 months ago

Having the same problem, started yesterday..

Visitor

 • 

3 Messages

@chuckdl​ Yeah, turning of ublock origin (Edge) worked.

Visitor

 • 

3 Messages

Firefox works for me after turning off ublock origin - Just FYI

Visitor

 • 

3 Messages

Turned off ublock on Chrome and it worked

Visitor

 • 

2 Messages

5 months ago

Same here. The problem started at noon yesterday.  It won't load beyond the three dots. Some other pages on the site are not loading properly too.  I tried all the trouble shooting protocols on multiple devices to no avail.  Online chat said a tech would call 10hrs ago-no call.

Visitor

 • 

2 Messages

4 months ago

fwiw Turning off ad blocker worked here.

Official Employee

 • 

979 Messages

@tenorsaxylady Thank you for letting us know what worked for you! If you have any other questions or concerns in regard to your services, please let us know.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

1 Message

4 months ago

just dropping by to say i was having the same issue, despite clearing cache, deleting cookies, etc. 

as tenorsaxylady mentioned, disabling adblocker fixed it for me.

1 Message

@user_vjkh33​ 

I had the same experience, starting yesterday around Noon. Disabling ad blocker fixed it.

Frequent Visitor

 • 

16 Messages

4 months ago

well well, turning off ublock origin (chrome on windows) worked for me too.  hmm.

1 Message

4 months ago

Having this issue. Cleared cookies, turned off Ublock, still nothing. 

2 Messages

4 months ago

It's really nice to see the Xfinity Support is helping us with this, NOT why is it that nobody from xfinity responds to these things, Oh yea it does not make them money so let the customer suffer. 

I don't have any add blocker extensions to turn off! 

Can we get some real answers?

Thank You.

Official Employee

 • 

960 Messages

@user_ehoo0b Thank you for reaching out via our Xfinity Forums. While we can certainly understand your desire to receive assistance with accessing the streaming app on your computer. The nature of forums, the Xfinity Forum has never been designed as a place to receive assistance in "real-time". In the future, if you are in need of immediate assistance we ask that you reach out to us via one of the methods shared here: https://forums.xfinity.com/t5/My-Account/ANSWERED-How-to-contact-Comcast/ta-p/3053370.

 

Have you had a chance to clear your cache and cookies and reboot your computer? These simple steps tend to clear most connection issues. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

4 months ago

I had the same problem that started two days ago. And sure enough, turning off ublock on the Xfinity stream page fixed the issue. 

Visitor

 • 

1 Message

Same problem. Streaming worked using Edge with no ad-blockers of any kind. Removing ad blockers on Chrome and Firefox did not work for me.  Xfinity support was worthless.

Official Employee

 • 

449 Messages

Thank you so much for sharing the fix with us @user_cda9ac! Please let us know if you have any further questions/concerns. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Official Employee

 • 

1.1K Messages

Hey @Samuel-27. After turning off the add blocker on either the Firefox or the Chrome, did you clear cache and cookies before trying to stream again?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Frequent Visitor

 • 

12 Messages

4 months ago

No ad-blocker on my Chromebook but still not working.  Stream worked the last 7 weekends to watch my football games, not this weekend.  I rarely need to use your Stream but football season is the exception and you totally let me down this time.  Thanks a lot, Xfinity.  

Frequent Visitor

 • 

12 Messages

finally got it to work on my Chromebook but I missed all the college football games I was going to watch today.  Needless to say, I'm P.O.'d at Xfinity for putting me through this.  The way I finally got it to work is that I had to put the built-in Chrome browser of my Chromebook into Incognito mode.  That makes no sense because you would think they would want to know my identity and whether I am a legitimate Xfinity Stream user, but no.  For all the advertisement they do telling how great Stream is (by the one slightly older kid telling some other slightly younger kids that they are lucky to live at this point in time because they have Stream), they should have techs making sure it works perfectly instead of making the customer jump through hoops for several days to get it to work.

1 Message

4 months ago

I am having the same problem.  I turned off my ad blockers, which did not resolve this.  I called Customer Service and they said Steam is no longer working through the Internet portal.

Official Employee

 • 

521 Messages

Hey there @user_38pax7 ! Thanks for reaching out about your trouble with the web portal streaming! I myself had the same issue, and I added xfinity.com/stream as a safe site on my ad blocker and got right back in. I am not sure what you may be using, but that is something to try if you are still having this issue!

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

1 Message

4 months ago

Turned off ublock from Microsoft Edge or from Task Manager > Processes. It worked immediately

forum icon

New to the Community?

Start Here