sable525's profile

New Poster

 • 

1 Message

Fri, Feb 12, 2021 7:00 AM

Xfinity Stream App not working on Roku

I've been on the phone and chat with xfinity tech support agents to no avail trying to fix why my streaming for live tv is not working... I have uninstalled and reinstalled so many times still nothing. I get the message 

Get more of what your looking for.( It looks like your plan doesnt include any channels, Luckily, theres an easy fix then tell me to go to xfinity website. ) 

Error Code TVAPP-00500

THEY HAVE SENT SIGNALS TO REFRESH MODEM AND NOTHING IS WORKING.. I KNOW HOW TO USE THE APP AS ITS BEEN THE SOURCE OF WATCHING TV FOR 2 YEARS... I THINK THEY WANT YOU TO RENT THOSE $8 BOXES PER TV.... CAN ANYONE TELL ME HOW TO FIX THIS ISSUE?

Responses

ComcastThomasF

Official Employee

 • 

106 Messages

2 m ago

Hello and thank you! I really appreciate you being a member of the Comcast Family! This is not the experience we want you to have with the Xfinity Stream App. Can you please send me a PM with your first and last name so I may further assist you? To send a private message, please click my name "ComcastThomasF" then select "Send a Message" on the right side.

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

1 Message

2 m ago

I don't know where on here I found this advice but it literally JUST worked for me. Thanks to the other poster for this advice and Comcast employee JONATHON whom she have credit to as well. 

 

1. Delete Xfinity beta app (highlight icon then press * key on Roku remote for options)

2. Unplug power supply from Roku stick for at least five mins, *** like walk away, lol 

3. Plug it back in, download app again, complete authorization process with link code to your phone or computer

4. Highlight Xfinity app again, press * to move channel where you want it again

 

***This time I left it alone for more than one minute and everything worked good once I authorized it again. Hope you have same results I had. 😊

New to the Community?

Start Here