PSUGOLD's profile

Contributor

 • 

81 Messages

Mon, Sep 21, 2020 4:00 PM

Roku TV Xfinity App issues with NBC10 Philadelphia only

I have a couple Roku TVs that I watch Xfinity at night with the Beta app.  Over the past few weeks, local channel NBC10 (Channel 810 here) starts out ok, then digitizes, then goes solid pink.  The sound stays on, so I can HEAR the show, but every time I put the channel on, this happens so I can not watch it.   I tend to watch that channel at night when I go to sleep, and now I can't.  Other channels seem ok.  I have uninstalled the app, reinstalled, no change.  Happens on 2 TVs, same issue.  Any ideas what this may be?

Responses

Rustyben

Expert

 • 

24K Messages

9 m ago


@PSUGOLD wrote:

I have a couple Roku TVs that I watch Xfinity at night with the Beta app.  Over the past few weeks, local channel NBC10 (Channel 810 here) starts out ok, then digitizes, then goes solid pink.  The sound stays on, so I can HEAR the show, but every time I put the channel on, this happens so I can not watch it.   I tend to watch that channel at night when I go to sleep, and now I can't.  Other channels seem ok.  I have uninstalled the app, reinstalled, no change.  Happens on 2 TVs, same issue.  Any ideas what this may be?


local channels are in mpeg2 which is approximately 2 times as much data bandwidth as regular cable channels. The router may not be reaching those Roku's with enough signal to have a good enough bandwidth stream. are you an xfi complete customer? are you able to connect (temporarily) via ethernet to the roku devices to verify the problem clears up?

PSUGOLD

Contributor

 • 

81 Messages

9 m ago

I am an xFi complete customer.  The router is downstairs, but both of my TVs have the same issue, and it just started about 3 weeks ago, and only on NBC10.  Every other local channel is fine, along with every other channel.  I've had the same setup for a while now, and watched NBC10 with no problems for months, all of a sudden it started with no real reason, and on both TVs, so that makes me think it is something with that one channel signal.  Just don't know what started it, and what can be done to fix it.

Rustyben

Expert

 • 

24K Messages

9 m ago


@PSUGOLD wrote:

I am an xFi complete customer.  The router is downstairs, but both of my TVs have the same issue, and it just started about 3 weeks ago, and only on NBC10.  Every other local channel is fine, along with every other channel.  I've had the same setup for a while now, and watched NBC10 with no problems for months, all of a sudden it started with no real reason, and on both TVs, so that makes me think it is something with that one channel signal.  Just don't know what started it, and what can be done to fix it.


can you specifically state what is happening or not happening when you tune to that channel? error message? error number? what device are you using for the stream app?

PSUGOLD

Contributor

 • 

81 Messages

9 m ago


@Rustyben wrote:

 

can you specifically state what is happening or not happening when you tune to that channel? error message? error number? what device are you using for the stream app?

There is no error message.  I am watching on a Roku TV on the Xfinity Stream app.   I tune to channel 810 (NBC10), it looks fine for about 10 seconds, then the top of the screen starts to digitize, then the screen will freeze, with the top part still looking broken up and digitized.  Sometimes the whole screen just goes pink or blue, but the sound never changes.  I can hear the show fine.  I change the channel and come back to NBC10, same thing.  Starts ok, then breaks up, then freezes, all with the sound staying OK.  This is the ONLY channel I have seen this with, and it started a few weeks ago, and happens on all 3 of my Roku TVs in different rooms.  Very odd, and annoying as I like to watch NBC10 at night in bed.

PSUGOLD

Contributor

 • 

81 Messages

9 m ago

FYI the issue is with the Xfinity Stream app on ALL devives.  I tried to watch NBC10 last night in bed on my iPad, and the channel froze too.  Sound ok.  Seems NBC10 is not working on any of their streaming platforms.

Rustyben

Expert

 • 

24K Messages

9 m ago

I have escalated your issue to the Comcast Team available to these forums. Check back often for a reply in this thread from a Comcast Official Employee.

Official Employee

 • 

2.9K Messages

9 m ago

Greetings, @PSUGOLD! I appreciate you taking the time to reach out to us here on the forums. I hope you are having an amazing day! I apologize to hear that you are running into issues with just this one channel. I know it can be frustrating when the channels you watch most start to act up. I would like to see what we can do for you. Can you please send me a PM with your first and last name so I may further assist you?

 

To send a private message, please click my name "ComcastMichael" then select "Send a Message" on the right side.

PSUGOLD

Contributor

 • 

81 Messages

9 m ago

Just a quick reply, whatever was wrong has worked itself out, and NBC10 is now ok on all the streaming devices.  All is well!

Official Employee

 • 

2.4K Messages

9 m ago

Fantastic. I am glad everything is working for you. Thank you for reaching out here on our community forums. Take care and thank you again for being a valued Comcast customer! 

New to the Community?

Start Here