JoePluta's profile

Frequent Visitor

 • 

11 Messages

Sat, Jan 18, 2020 1:00 PM

Port Forwarding no longer works, and cannot be configured via 10.0.0.1

Recent firmware upgrades have made it so that the Xfinity router interface available through 10.0.0.1 no longer allows you to configure port forwarding.  Instead, a box tells you to go to xfinity.com/myxfi.  Unfortunately, even that doesn't work.  I can configure a port, or a port range, and it works once, but then it stops working.  I have been on the phone with support for roughly 12 hours over the last five days, and at the end of it they told me they were going to report it.

 

This used to work until they forced me to swap out my modem for a TG1682G.  That's the first one that no longer supports changing port forwarding via 10.0.0.1.  My working port forward stopped working and I had trouble configuring others.  Next they told me to swap for a TG3482G, which I did but the same issue occurs.

 

So right now port forwarding doesn't work and Comcast says they don't know why.  Does anybody have port forwarding working with a TG3482G?

 

Responses

Accepted Solution

Official Employee

 • 

712 Messages

1 y ago

Hi @Acleve, sorry to hear you have been experiencing this issue with port forwarding. If you have an xFi Gateway, port forwarding is no longer supported through 10.0.0.1, instead, we recommend that you use xFi.

My recommendation would be to log into 10.0.0.1 and undo any device/static IP settings that you may have put in place to set up the port forward.

Once you have done that, log into xFi and navigate to Network > Advanced Settings > Port Forwarding. To set up the port forward, select the camera from the drop down list of devices (note, the cameras need to be connected to your home network in order to show up in the drop down list), and configure the ports as needed.

Once you establish the port forward rule, xFi will create a static MAC bind for that device. The MAC bind enables xFi to keep the port forward rule in tact whenever the camera's IP address changes from the DHCP.

 

In regards to Advanced Security, any outside access attempt to a device on your network through open ports will be seen as a threat. There are two common threats for open ports - Unauthorized Access Attempts and IP Reputation. IP Reputation threats are those that are coming from known malicious sources. Unauthorized Access Attempts are access attempts that are not recognized as coming from a malicious source, but you should still take caution. 

Any attempt you make to access your camera feed from outside the home would likely register as an Unauthorized Access Attempt. If you know the Source IP and Port of the device you are using to access, you can view the threat and allow access. To do this, log into xFi and navigate to Network > Advanced Security > Select your device (camera) > Unauthorized Access Attempt > Threat History, identify that specific threat and "Allow Access". This will allow that device to access the port for 30 days.  If you need to check the source IP of your device, you can use https://whatismyipaddress.com/

 

I hope this information helps. 

Visitor

 • 

1 Message

@ComcastBrittany Did the Same For Me. 

What If My Gateway Is Not xFi? 

Official Employee

 • 

712 Messages

1 y ago

Hi @Lisa-Pluta, have you reviewed the troubleshooting tips in this post

 

It sounds like you are initially able to set up the port forwards, however after a few days they stop working. Is this accurate?

Do you have static IPs set for these devices in 10.0.0.1?

 

New Poster

 • 

4 Messages

1 y ago

I have a FLIR MPX DVR (home surveillance cameras) that the mfg stated needed to be set up with Port Forwarding to view the cameras from my phone, ipad, etc. when I'm not home.  Went thru all the steps to set it up thru the modem, then  the troubleshooting, then the call to Comcast, etc. & it still doesn't work.  Used the 'open port check tool' and found out the Port that we need is 'Closed' - had 2 Xfinity Technicians at my house for 2+ hours trying to fix the issue (without success) - they were on the telephone with 'Level 2' technicians who also could not solve the problem.  I need Comcast/Xfinity to Open the Port, Assign an IP Address so my system works...and I keep getting some repititive message that XFi Advanced Security is blocking a threat from my camera system!  This is proving to be one of the most frustrating experiences I've ever had with Comcast - which I use for cable, phone, security, and internet...

EG

Expert

 • 

87.1K Messages

1 y ago

Disable the advanced security feature, it's buggy;

 

https://www.xfinity.com/support/articles/using-xfinity-xfi-advanced-security

New Poster

 • 

3 Messages

1 y ago

As of 5/1/2020 there are no port forwarding controls in xfi under the network area of the online tools. How does one put in a port forward now?

 

Thanks.

New Poster

 • 

2 Messages

1 y ago

I used to host an Ark server for my kids, that worked perfectly for 6 months. Nothing changed in my system besides time. 6 months have passed and I restarted the server.  LAN connection to server no issues, but the public server is not open, thier friends cannot join.

Before you say port forwarding, done, double checked...octo-checked? (is that a thing???) Cause I certainly went over it more than 8 times.

I hired an IT person to set up the servers a year ago, and I truly have not changed a thing.  Did Comcast elimiate this ability? I also noticed when I went into the port forwarding screen, I tried to add one, and for a week I get the message to try again later ot restart router. (15 restarts & 7 days later) Im still getting the message.

New Poster

 • 

1 Message

1 y ago

juddacus:

The following steps may not be the most direct but they should work for you.

1. go to xfinity.com/myxfi from either within your Xfinity router 
2. log into your xfinity account if prompted.
3. click next until you get to the Xfinity Overview screen
4. Click Network
5. Under network Devices, click the > chevron
6. Scroll to bottom of web page and under More >> Advanced Settings click the > chevron.
7. Click the > chevron
8. You now be on the Port Forwarding page.
9. click the add Port forward button if no entries are listed, or, click the edit/add buttons if there are entries already listed.

 Note:  https://internet.xfinity.com/network/advanced-settings from your browser should take you directly to the page in step 5 if you are already logged into your Xfinity.com account.

 

Yes, this is very clunky and user unfriendly and I wish Comcast would just bring back the Admin console.

 

Hope this helps.

 

Visitor

 • 

2 Messages

2 m ago

I had the same problem.  It only works when I have my port forwarded devices within the DCHP range.  So basically it all of the sudden quit on me, then after a ton of trials.  I had to setup my DCHP range to be from .11 - .253 rather than .100 to .253..   Hope it holds?  So now my statics are within the DCHP range which scares me.  Also I saw a setting under "connected devices" called "add device with reserved IP"..  So I entered the MAC addresses along with the IP I have assigned the device.  But I don't know if this is even the right thing to do.

EG

Expert

 • 

87.1K Messages

2 d ago

Re-closing this year old dead thread that was improperly re-opened by the new forum software / platform. A known issue that is being worked on.

New to the Community?

Start Here