Spokane44's profile

New Poster

 • 

2 Messages

Tue, Oct 24, 2017 2:00 PM

Closed

Xfinity 4k - XG1v4 Cable Box Availability

Called Xfinity and asked about the availability of XG1v4 cable boxes at my location (WA state), which has the capability to stream 4k content through Netflix.  Was assured, with repeated confirmations, that they were available to the local service store, would just have to bring in my existing cable box and exchange it.  Bought a nice LG OLED TV, upgraded my Netflix account to receive Ultra HD, and took my box down to the local service center for exchange, per customer service direction.  You can probably guess what happened next - "sorry, we don't have any 4k boxes, don't know when we will".  Anyone else been misled by the Xfinity garbage customer service?  Went online to see what lies they convey on their website regarding this matter, and found this:  https://www.xfinity.com/support/cable-tv/uhd-4k-faqs/   More misleading BS.  Wanted to warn anyone else potentially in the same situation as myself not to believe anything you are told or read about the availability of XG1v4 boxes; go to your service center first to confirm.

This conversation is no longer open for comments or replies and is no longer visible to community members.

Regular Visitor

 • 

1 Message

5 years ago

I also would like to order a XG1v4 4k box.  I went to my local Comcast store and was told I needed to order one online or over the phone.

CCElla

Gold Problem Solver

 • 

3.3K Messages

5 years ago

Hello all,

 

My apologies for the delayed response. There is currently a limited availability of 4K cable boxes due to a high demand. I cannot guarantee that we will be able to ship a new box right away but I can definitely put a request. Please send me a private message with your name, address, and a phone number associated with the account and I will put a request. 

 

Thank you @Rustyben for mentioning my handle is this thread, greatly appreciate it. 

Frequent Visitor

 • 

8 Messages

5 years ago

I have been stopping in my store for over a month to try and get a new box that supports 4K.  I purchased 2 new 4K TV's, upped my internet from the 150 to 300, upgraded my NetFlix to the 4K package, but they keep telling me that they are out of stock.  One time they had it bt wouldn't hold it since it was about a 40 minute round trip to home and back and it was gone when I got back.  😞  I keep trying and I stop in almost every day after work, but no luck.  Guess they are hard to get, but the Comcast employees tell me they have them and that they are great.  Can someone who has it verify if the Netflix 4K looks good?  I'm excited and can't wait to get a new box.  Hope I get to get a couple soon (one to replace my DVR and the other for my extra HD reciever)!  Let me know what you guys think of the picture and if it's worth the wait!!  🙂

Rustyben

Expert

 • 

24.5K Messages

5 years ago


@Ghost_Evo wrote:

I have been stopping in my store for over a month to try and get a new box that supports 4K.  I purchased 2 new 4K TV's, upped my internet from the 150 to 300, upgraded my NetFlix to the 4K package, but they keep telling me that they are out of stock.  One time they had it bt wouldn't hold it since it was about a 40 minute round trip to home and back and it was gone when I got back.  😞  I keep trying and I stop in almost every day after work, but no luck.  Guess they are hard to get, but the Comcast employees tell me they have them and that they are great.  Can someone who has it verify if the Netflix 4K looks good?  I'm excited and can't wait to get a new box.  Hope I get to get a couple soon (one to replace my DVR and the other for my extra HD reciever)!  Let me know what you guys think of the picture and if it's worth the wait!!  🙂


hi, I moved your post to the xg1v4 mega-thread. @CCAndrew may look in on this soon and perhaps refer to arrange to get what you need.

cldlhd

Regular Contributor

 • 

482 Messages

5 years ago


@Ghost_Evo wrote:

I have been stopping in my store for over a month to try and get a new box that supports 4K.  I purchased 2 new 4K TV's, upped my internet from the 150 to 300, upgraded my NetFlix to the 4K package, but they keep telling me that they are out of stock.  One time they had it bt wouldn't hold it since it was about a 40 minute round trip to home and back and it was gone when I got back.  😞  I keep trying and I stop in almost every day after work, but no luck.  Guess they are hard to get, but the Comcast employees tell me they have them and that they are great.  Can someone who has it verify if the Netflix 4K looks good?  I'm excited and can't wait to get a new box.  Hope I get to get a couple soon (one to replace my DVR and the other for my extra HD reciever)!  Let me know what you guys think of the picture and if it's worth the wait!!  🙂


If your 4k tv's are smart tvs I'd use the native app. The netflix app  on the xg1v4 looks good but so does the tv app most of the time.

Cydeweyz

Contributor

 • 

75 Messages

5 years ago

And the TV Netflix app will do HDR.
I just received and installed my XG1V4 today. Ordered over the phone last Friday. I got the same no stock stories at a couple stores as well. The 1st store said no stock in any store in North America. Maybe some in Mexico or India. I figured they were just brushing me off, but who knows. Shipping was painless though.

Frequent Visitor

 • 

8 Messages

5 years ago

@Rustyben Thank you for your help with this, I appreciate it.

 

@cldlhd Thank you for your response.  Yes, they are.  They are Samsung 8000 series TV's and do have the app.  The TV apps never seem to search or as "snappy" as other dedicated boxes that provide the apps.

 

@Cydeweyz Thanks for your report.  Two nights ago the guy at the store changed out my DVR box for some odd reason ("for my troubles" since I made the trip with all of my stuff in hand), however the box he gave me when I got home and unwrapped it from the cardboard and shrink wrap) was all scratched up, had a green button instead of the blue one my old one had, something is loud and has a squeal to it (like a bad cap), and the audio cuts out in the middle of shows and comes back on spurradically.  I wish I would have just kept my old box now.  I had to reboot the old box once a week because it would freeze and act wierd (but it wasn't too inconvienient) this one seems old and sluggish (almost like it can support the X1 platform efficiently).  😞

 

I hope someone is able to help on the forums and I can just change out the equipment with the 4K stuff, but if not I'll just run back to the store and try and get a quieter DVR with one that doesn't lose sound for the time being.  Thanks again for your replies, much appreciated!

Frequent Visitor

 • 

8 Messages

5 years ago

My OLD box that they kept looked like the old box you have on the bottom with the blue light (mine may have had a USB slot under the blue botton as well I think), the one that they gave me does not.  The box they gave me looks similar, but has a green light (instead of blue) and if I remeber right a couple of push puttons on the front under the clock.  Sorry, trying to do this from memory from work.  🙂

 

The remote I have is the old one (one on top).

 

Thanks again!

Cydeweyz

Contributor

 • 

75 Messages

5 years ago

New box on top of the old box. New remote next to old one. Does what you have look like this?
Rustyben

Expert

 • 

24.5K Messages

5 years ago


@Ghost_Evo wrote:

@Rustyben Thank you for your help with this, I appreciate it.

 

@cldlhd Thank you for your response.  Yes, they are.  They are Samsung 8000 series TV's and do have the app.  The TV apps never seem to search or as "snappy" as other dedicated boxes that provide the apps.

 

@Cydeweyz Thanks for your report.  Two nights ago the guy at the store changed out my DVR box for some odd reason ("for my troubles" since I made the trip with all of my stuff in hand), however the box he gave me when I got home and unwrapped it from the cardboard and shrink wrap) was all scratched up, had a green button instead of the blue one my old one had, something is loud and has a squeal to it (like a bad cap), and the audio cuts out in the middle of shows and comes back on spurradically.  I wish I would have just kept my old box now.  I had to reboot the old box once a week because it would freeze and act wierd (but it wasn't too inconvienient) this one seems old and sluggish (almost like it can support the X1 platform efficiently).  😞

 

I hope someone is able to help on the forums and I can just change out the equipment with the 4K stuff, but if not I'll just run back to the store and try and get a quieter DVR with one that doesn't lose sound for the time being.  Thanks again for your replies, much appreciated!


that is the oldest model of x1 DVR and has component cable outputs. it has only 5 not 6 tuners available and is known for sound dropouts. the squeal is the failed hard drive. take it back and get at least a xg1 verson 3. if you have 4k TV ask for an xg1 version 4

New Poster

 • 

5 Messages

5 years ago


@Cydeweyz wrote:
New box on top of the old box. New remote next to old one. Does what you have look like this?

In your picture, the top box is the XG1v4 (W/Netflix 4K) and the bottom remote is the one that goes with it. They both work perfectly for me.

 

Just say'n....

SiegeX

Frequent Visitor

 • 

13 Messages

5 years ago

When I received my XG1v4 a few weeks ago I promptly set the skip from 5min to 30sec via the remote code: EXIT-EXIT-EXIT-0-0-3-0

This code worked great...until yesterday when I noticed my skip was back to 5min, must have been some overnight upgrade that reset it. Now when I try to put back the 30sec skip with the same code it no longer appears to work.

Anybody get the same behavior and/or have been able to set 30sec skip recently?

I’m currently on “STB Version” AX014AN_2.13p19s1_PROD_sey (from About page)

-=UPDATE=-
Looks like all I needed to do was a “RESET” through the settings menu. Not sure why it was necessary as I didn’t have to do it last time.
Rustyben

Expert

 • 

24.5K Messages

5 years ago


@SiegeX wrote:
When I received my XG1v4 a few weeks ago I promptly set the skip from 5min to 30sec via the remote code: EXIT-EXIT-EXIT-0-0-3-0

This code worked great...until yesterday when I noticed my skip was back to 5min, must have been some overnight upgrade that reset it. Now when I try to put back the 30sec skip with the same code it no longer appears to work.

Anybody get the same behavior and/or have been able to set 30sec skip recently?

I’m currently on “STB Version” AX014AN_2.13p19s1_PROD_sey (from About page)

-=UPDATE=-
Looks like all I needed to do was a “RESET” through the settings menu. Not sure why it was necessary as I didn’t have to do it last time.

many customers have reported this issue, fixed by either a reboot of the box (the setting fixes itself) or resetting the option like you did. Comcast says in replies that the firmware upgrade does not cause this, but it only happens after a firmware upgrade and affects customers apparently at random.Reboot your set top box (unplug from power for 30 seconds or so) and the issue should be fixed.

Frequent Visitor

 • 

8 Messages

5 years ago

Thanks for the reply. Took the box to the Xfinity store today and they gave me a V3 box from what I’m told. I do have a few 4K TV’s but they don’t have the V4 boxes.

The guy told me to call the Xfinity number or get on the forums and someone may be able to get me a 4K. Anyone here able to help? Haha.

I’m sure the sound cut out and box squeal from the old box will go away with this replacement at least. 🙂

Frequent Visitor

 • 

8 Messages

5 years ago

Well, that excitement as short lived. Hooked up the box that they gave me when I got home, and after 20 minutes of looping and not completely booting up (and trying to power cycle it a few times), this box is apparently not good (should have kept the squealing one).

Decided to try and call customer service for a replacement box and hopefully a V4... and was told to go to the local store and pick up a V4 box to work with my 4K TV’s. I told them they were out according to the guy at the store, and they said they couldn’t help and I should just go back and get a regular replacement box again... so disappointed today. 😞

I guess I’ll go back and get another box to replace this one for the third time. Right now I wish I would have gotten a V4 box first instead of buying the TV’s, upgrading my internet, and upgrading my Netflix first. Comcast guy made it seem like the local store had a boatload of them. My fault for spending that much money and not making sure they had the V4 box first.

Glad other people on the forum are getting help with their boxes. If anyone here can help me order a V4 box please let me know. Don’t want to message the mods without permission because it’s a violation of the forums I guess.

Thanks again in advance. Off to the local store again...
forum icon

New to the Community?

Start Here