prh7270's profile

Frequent Visitor

 • 

5 Messages

Fri, Feb 12, 2021 4:00 AM

Dolby 5.1 surround sound

I have been a xfinity customer for about 5 years, moving from another area and cable company.  One thing that has bothered me for some time is the audio feed from most if not all channels. It really came to light when I tried the free trial of sling tv last night.  I was watching a version of the show chopped on sling tv. I could hear things in all of my 5.1 speakers... things rattling in the background, more like you should experience.  I have never heard this on the xfinity version. Things like sporting events are not the same, I used to hear crowd noise from my speakers, more like you expect from a surround system.  

I have the hdmi output from my xfinity 4k box going to a hdmi splitter, then that goes to my LG oled tv, and that feeds my 5.1 receiver with an optical cable.  

Is xfinity broadcasting things without this audio ?  I recently just set my xfinity receiver to expert mode with the audio output, not noticed anything really different.. 

 

Thanks.

Responses

Accepted Solution

prh7270

Frequent Visitor

 • 

5 Messages

4 m ago

I seem to have narrowed down the problem.  It seems to be the hdmi extender I am using.  I have the Xfinity receiver plugged into the extender,  then the extender into the tv.  If I plug it directly into the tv, the sound works fine.  So, it's my setup.  Thanks for the help. 

New Poster

 • 

2 Messages

Typically the AV receiver would be the hub of the system. Have you tried xfinity box > hdmi > AVR > hdmi > tv ?

Official Employee

 • 

6.7K Messages

4 m ago

Hello prh7270. Thanks for creating a new post on our Forum about Surround Sound. We do have a recent thread with dialog featuring the same surround sound questions you have. You can the thread here:

https://forums.xfinity.com/t5/X1/Re-Not-all-HD-channels-giving-me-5-1-surround-sound/td-p/3301540

For a complete setup guide to setup your home theater for surround sound, please visit: https://www.xfinity.com/support/articles/troubleshoot-home-theater-receivers

Note: Not all Dolby Digital® programs feature full 5.1 surround sound. In some cases, the programs may only contain left and right stereo audio.

prh7270

Frequent Visitor

 • 

5 Messages

4 m ago

So... yesterday I tried a little experiment.. I used netflix inside the xfinity system.. My receiver only picked up standard PCM stereo sound on a program I know broadcasts in dolby surround sound. I then went to netflix on my amazon firestick that is plugged directly into the tv.. and the receiver picked up dolby surround.. The only thing I can get out of my xfinity box is pcm stereo..

ComcastAbbie

Official Employee

 • 

315 Messages

4 m ago

Hello, and thanks for using Xfinity Forums. I appreciate you reaching out with these concerns. I would like to look further into this to see what I can find regarding the audio for your specific box. Please send me a private message and include your first and last so I can assist you. To send me a Private Message, please click my name “ComcastAbbie” and click “Send a message"

Visitor

 • 

1 Message

I am having the same issue with my XG1v4 box. My TV only shows Stereo PCM, no matter what I watch. If I switch to a different input source, my TV will show 5.1. I have my XG1v4 set to "Expert Mode", am I missing something?

ComcastAmira

Official Employee

 • 

2.3K Messages

Hello @user_8c22c8, thanks for reaching out to us on Forums in regard to you experiencing similar issues with your 4K cable box. My team would be more than happy to assist you with further looking into and troubleshooting this on our end. For further assistance, please send us a Private Chat Message.

 

To send us a Private Chat Message, select the message icon in the top right corner and then search for Xfinity support. With our new Xfinity support chat, you do not need to input the name of a person. Just select Xfinity support and you will be able to speak with the next available specialist.

Official Employee

 • 

105 Messages

4 m ago

Thank you @prh7270 for letting us know you were able to narrow down the issue and were able to resolve the issue at hand with your sound. Please let us know if anything else ever comes up. We are always here and happy to help you 24/7 365. Take care! 

New Poster

 • 

3 Messages

1 m ago

I’m having the same issue, only PCM through my Xfinity 4K box, please help!

Official Employee

 • 

268 Messages

Thank you, @ for reaching out to us over our Community Forums. I found a great article that may help with your audio setting on the X1 system. Please take a look, and let us know if that helped. 

 

https://comca.st/33GD8gm

 

If you are still having an issue, please let us know what type of audio setup you have connected to the X1 box. Thank you! 

BrianHCM1

Contributor

 • 

28 Messages

1 m ago

I'm now only getting PCM on my X1 box. Auto Detect 5.1 work up to last month. I have an older surround receiver and using a 4K audio extractor with the box. Again, its been working perfect up until recently on "Auto Detect". Now it says Auto Detect (Dolby Digital Plus) under it says "HDMI output based on capabilities of you connected audio system". I though that would be more in line with "Expert Mode". If I switch it to Expert Mode, it works for regular TV, but not Netflix for example. I get absolutely no output for Auto Detect, so I think it must have been an update on your end that preventing it from working now. Is there anything you can recommend to get me up and running again without buying a new Home Theater system?

andyross

Silver Problem Solver

 • 

6.9K Messages

There seems to have been a recent firmware update that messed up any audio that comes from IP streaming. That includes apps, Cloud DVR, IP channels, and most OnDemand. On my XG1v4, all of that, when in Expert HDMI mode, is coming up as DD+5.1. That is happening for shows or services that I know are only DD2.0.

Visitor

 • 

11 Messages

1 m ago

Loss of voice audio on center channel speaker

Below is a post that I posted.  Thought I would copy it over to this thread,

I have a Dolby Atmos Home Theater system with a 4k Xfinity cable box.  During the NFL season I could not hear the referee announce the calls.  Found that the ref was not being broadcasted over the center channel speaker even though the announcers were.  Went to my nephews house who has a 5.1 system with a 4k cable box and he did not have this issue.  In Jan I returned my 4k box for another one.  Problem did not go away.  I have also discovered that on the TV show The Voice the announcer, judges and contestants come over the center channel fine.  But when the contestants sing their voices disappeared on the center channel.  When I play the You Tube app via the 4k box I do not get voice audio on the center channel but when I play the same You Tube content via my Apple TV everything is fine.  

I have spoken to Xfinity CS and they sent out the technician who I demonstrated my issue to and he was completely befuddled. His suggestion was to replace my 4k box with an HD box which I do not want to do.  I would like to know if anyone else is having this issue.  Thanks.

New to the Community?

Start Here