U

Visitor

 • 

1 Message

Sun, Mar 6, 2022 4:06 AM

Xfinity remote repeatedly loses connection with cable box

We recently upgraded our Cable service to have more channels. The new remote kept losing its pairing/connection with the new cable box. It would work for a day, then after turning off the TV overnight or for a while, upon turning it back on, the remote wouldn’t work - couldn’t adjust volume, change channels, see the guide, etc. I could re-connect the remote with the box only by removing the batteries from the remote, unplugging the cable box from power, then plugging the box in again, replacing the batteries and letting the box reboot. After a couple of weeks of this, I exchanged the box and remote at our local Xfinity store for new ones. But the same thing continued to happen. I then replaced the TV with a brand new one. Same problem. The. I replaced the HDMI cable. Same problem. We are not having any problems at all with the bigger TV, which is connected to the DVR. Help!

Official Employee

 • 

566 Messages

5 m ago

Hello @user_8eaafc and thank you for taking the time to create this post for our Xfinity Community Forum! I am sorry to hear about the troubles with your remote pairing with your new cable box; this sounds very frustrating! You're in the right place for help.

 

Please send a private message with your first and last name, as well as complete service address to "Xfinity Support". To do so, click on the chat icon located at the top right of this forums page.

 

  1. Click "Sign In" if necessary
  2. Click the "Direct Messaging" icon (upper right corner of this page)
  3. Click the "New message" (pencil and paper) icon
  4. Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list
  5. Type your message in the text area near the bottom of the window
  6. Press Enter to send your message

 

I look forward to working with you soon!

Visitor

 • 

2 Messages

3 m ago

I am having the same problem, what is the fix for this?

Official Employee

 • 

70 Messages

Hello there, @user_608227. The thread owner mentioned some really awesome self-service options they attempted to resolve the issue by replacing the batteries and performing some resets to the cable boxes and remote with different batteries. Have you attempted any of those steps by chance? Did you recently replace a remote or cable box recently?

 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

2 m ago

This is happening to my remote and cable box every day. It’s annoying and I’ve done everything to fix it myself, reset box, re-pair remote, change batteries, etc. I’m ready to switch to another provider. 

Official Employee

 • 

511 Messages

Hi, we would love to look into your remote concern. Have you tried swapping your box for a newer one? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

Yes we got a new box and remote, did not fix it.

XfinityKorie

Official Employee

 • 

788 Messages

We'd love to help! Can you send us a PM with your name and address? 

 

To send a "Peer to peer" message:

Click "Sign In" if necessary

• Click the "Peer to peer chat" icon

• Click the "New message" (pencil and paper) icon

• Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list which appears. The "Xfinity Support" graphic replaces the "To:" line

• Type your message in the text area near the bottom of the window

• Press Enter to send it

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

2 m ago

I'm having same issue. Constantly have to pair to box. Do I just bring the box to the store and ask for a new one?

Nashtn

Contributor

 • 

40 Messages

2 m ago

Is the light on the box on? When you installed the new box, did you install the new power cable, new hdmi cable, and use the new remote that came with it?  

(I learned last week when two of my mom's tvs would not work that the power cords to turn on the boxes fail.)  I would take the box, power cord, hdmi cable, and remote back and swap all at the store.  

Visitor

 • 

1 Message

1 m ago

I’m having the same issue.  Been going on for 4-5 months. Any resolution, or just swap boxes and hope for the best?

Visitor

 • 

1 Message

1 m ago

This is also happening to me. Just started a week ago. Every morning I have to reprogram the remote. Anyone have a fix?

Official Employee

 • 

310 Messages

Hello, @user_d081e1

Thank You for taking the time to reach out to Xfinity Support, here on the Community Forum. I am sorry to read of your difficulties with the remote.

I would start by unpairing the remote;

https://comca.st/3z40HAi

Then, pair it again;

https://comca.st/3zbQKkp

If this does not resolve the issue, we can replace it;

https://comca.st/3AMxniI

Also, I love the Xfinity TV Remote App;

https://comca.st/3RubJpu

I hope this helps

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here