CAElljay's profile

Visitor

 • 

1 Message

Thu, Jul 8, 2021 9:44 PM

Searching for Signal?

Two of my three tvs are having problems receiving adequate signal. It is sporadic but most frequently occurs during high usage times or high view programming.  Sometimes there is no picture, sometimes there is pixellation, sometimes the image from another channel bleeds over. I have TiVOs on both of these tvs (different models) and yet another TiVO on the tv that is fine. Comcast has come out twice. The first time I was told it is because of congestion on the lines since so many people are home during COVID. The second time I was told that I need to replace the cabling in the house. I question why two separate cables would fail at the same time while the third cable is just fine. The technician told me that the amp boosting all three cables is fine. Before I spend the time looking for options other than Comcast, or before I spend the money to run new cable, I would like some suggestions as to how I can diagnose whether this is related to neighborhood congestion, bad cables, bad amp, or TiVO compatibility. Thanks!

Responses

BruceW

Gold Problem Solver

 • 

22.9K Messages

3 m ago

These Tivo installation and troubleshooting articles may help:

    CableCARD Installation
    CableCARD Troubleshooting
    Pair or Activate Your CableCARD

    Troubleshooting Digital TV Signals

Good luck!

EG

Expert

 • 

89.2K Messages

3 m ago

Concern moved here to the proper help section.

Official Employee

 • 

199 Messages

3 m ago

Hello @CAEllijay. I am sorry to hear you are having so much trouble with you cable services. I would love to do some troubleshooting with you to see about getting this resolved. Please send me a direct message with your first and last name, along with your complete service address to “Xfinity Support”. To do so, click on the chat icon located at the top right of this forums page.   

 

Here are detailed steps to direct message us:  

 • Click "Sign In" if necessary 

 • Click the "Peer to peer chat" icon (upper right corner of this page) 

 • Click the "New message" (pencil and paper) icon 

 • Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list 

 • Type your message in the text area near the bottom of the window 

 • Press Enter to send your message 

New to the Community?

Start Here