BruceW's profile

Gold Problem Solver

 • 

25.5K Messages

Tuesday, February 27th, 2024 2:13 PM

Forum editor ignores edit attempts

The Forum editor has started ignoring Comment and Reply edits, perhaps as a result of the changes which added the "Drop files here, or browse" option below the editor window. The first post in a topic seems OK, but later Comments cannot be edited. By that I mean the Forum editor works fine for me while creating a new message, but after that message is Posted when I click the Edit option on the triple-dot "menu" and try to revise the message "Failed to update" pops up and the edits I made to that existing, posted message are discarded.
 
Tested in Firefox, Chrome, and Edge. I can edit, but when I click 'Post' the edits disappear and the post reverts to what is was before the edit was attempted. The only way I can 'edit' is by copying the original into a new Comment, making my changes, posting the new Comment, and then deleting the original post. 

Could this be fixed please?

ETA: Clarify that "edit" means an attempt to modify a previously posted message.

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

Accepted Solution

Official Solution

Retired Employee

 • 

5.9K Messages

1 month ago

All,

An update was made that should have resolved this issue for impacted users. We ask that you please clear your browser cache and cookies and retest. Please let us know if you are still experiencing this issue. 

Accepted Solution

Gold Problem Solver

 • 

25.5K Messages

1 month ago

"Edit" appears to be working again. Was something fixed, or is this a fluke on top of a fluke? If fixed, "thank you!" to all who made it happen.

OTOH there are still no notifications for Replies.  :-(

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.
 

(edited)

Expert

 • 

30.3K Messages

@BruceW​ 

It's about time!

And I see our attachments are no longer at the bottom of the Body.  Removing them apparently brought the Edit function back, so it was the addition of all those files for attachments that broke the Edit feature.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Please mark an Accepted Answer!tick

Retired Employee

 • 

5.9K Messages

2 months ago

@BruceW 

We are unable to replicate this issue with either an employee or customer profile. Can you please clear your browser cache and cookies and retest? 

If you still experience issues, please let us know. 

(edited)

Gold Problem Solver

 • 

25.5K Messages

2 months ago

In Firefox, Chrome, and Edge, I logged out of the Forum and Xfinity, deleted cookies for Comcast, Sprinklr, and Xfinity, cleared cache, and closed the browser(s). Then reopened each one and logged back in to Xfinity and then Forums. Edits still do not work. They continue to behave as described in my OP.

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

Gold Problem Solver

 • 

25.5K Messages

2 months ago

When I click Post after making an edit, the following flag appears at the bottom of the window:

Gold Problem Solver

 • 

25.5K Messages

And if I try to edit a Reply, I get:

Gold Problem Solver

 • 

25.5K Messages

2 months ago

The problem with edits began on the same day as the following was added, just below the editor window:

Drop files here, or browse

Allowed file types: All image, video, text files supported; Additionally: .pdf, .doc, .docx, .xml, .xls, .xlsx, .csv, .cdxml, .cdx, .mol, .sdf, .zip, .gz

Maximum upload file size: 10 MB

It seems likely that these two things are related, i.e., that Sprinklr broke "Edit" when they made this change. Note that the "Drop files here, or browse" text does not appear when editing the OP of a topic, and that OPs are editable. This does not seem like a coincidence.

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

Retired Employee

 • 

5.9K Messages

@BruceW 

We apologize you are experiencing this issue. You are welcome to share browser/version-specific details that we can share with our platform partners. 

As mentioned previously, after testing with multiple users, we are unable to replicate this issue you are experiencing at this time (notice the edit "tag" on my original reply and this message), but we are happy to get this reported on your behalf. 

If we have updates to share, we will be sure to post them here. 

(edited)

Gold Problem Solver

 • 

25.5K Messages

2 months ago

... You are welcome to share browser/version-specific details  ...

Browser versions:

    Firefox:    115.0.3 (64-bit)

    Chrome:  122.0.6261.95 (Official Build) (64-bit)

    Edge:       122.0.2365.59 (Official build) (64-bit)

I am using an HP desktop running Windows 11.

All three browsers display the "Failed to update" message when I try to edit a post.

Also, three years after the Sprinklr forum launched, I still do not receive any notification for Reply messages (not by email, and not via the "bell" icon). I get them for Comments, but not for Replies. I did not know you had Replied at 9:12AM until I loaded the thread to see if there had been any activity. It's disappointing that the Reply Non-Notification problem has gone on so long with no attempt to fix it.

And so please, please, please note that: When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

Retired Employee

 • 

5.9K Messages

@BruceW I have reported this to our platform vendor. As soon as I have any update or additional information to share I will be sure to do so here. 

Expert

 • 

30.3K Messages

2 months ago

@BruceW 

In your Profile under Notifications & Preferences do you have everything turned ON?

This is what I have checked:

Even @ tagging should work for you.  And, fwiw, this was copied via FF.  And I, too, am having problems with the Editor.

Gold Problem Solver

 • 

25.5K Messages

2 months ago

... In your Profile under Notifications & Preferences do you have everything turned ON? ...

Everything is turned on, for both Email and Platform, except Badges. All of these options (including Badges) have been toggled off and back on multiple times over the past three years, but no bueno for either kind of Reply notifications, ever.

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

Expert

 • 

30.3K Messages

@BruceW​ 

... In your Profile under Notifications & Preferences do you have everything turned ON? ...

Everything is turned on, for both Email and Platform, except Badges. All of these options (including Badges) have been toggled off and back on multiple times over the past three years, but no bueno for either kind of Reply notifications, ever.

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

Okay, so you've toggled them on and off over the years.  When you've turned them off have you then cleared your cache and cookies and closed your browser and then started a new session? going back to turn them on, clearing your cache and cookies again, closing your browser and starting a new session again?

I've talked with @XfinityJessie about this problem you're having and she said that you should at least get notifications from @ tagging.  We do agree that there is a definite problem you're having with this but can't figure out why.  It all should work for you if you have all of those checked.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Please mark an Accepted Answer!tick

Contributor

 • 

146 Messages

2 months ago

Hello Community ,

 I'm having trouble with editing my posts , I do so but afterwards I see that the change isn't made ?  About the past 48 hours this began .  Any suggestions much appreciated .

🤷‍♀️

Note: This comment was created from a merged conversation originally titled Edit Post

Gold Problem Solver

 • 

25.5K Messages

2 months ago

... When you've turned them off have you then cleared your cache and cookies and closed your browser and then started a new session? going back to turn them on, clearing your cache and cookies again, closing your browser and starting a new session again? ...

Cache and cookies have been cleared many, many times, although not in that particular sequence. I just followed those steps and will let you know if it works. My instincts are that it will not, but I'd be happy to be wrong about that.

... you should at least get notifications from @ tagging ...

That would be nice, but it doesn't happen. I do get tagging notifications when the tag is posted in a Comment, but not when it is posted in a Reply. Examples: I received email and "bell icon" notices when you and Jessie tagged me in Comment posts in this thread, but no notices when the two of you tagged me in Reply posts.

@Again: in https://forums.xfinity.com/conversations/email/no-forum-email-notifications-since-42/60763a2af024b802281d0bd2?commentId=60bb7eee6c59237a14d5598f&replyId=60bd522eae2a02023052f48e in 2021 you wrote:

...  I don't get notification for "Reply", either. ...

Is that still the case, or has that been fixed?

Back at the "Edit doesn't work" problem, It occurs to me that another recent Sprinklr change is the notice they added when my login to the Forum times out:

I continue to think that one or more of these recent changes has munged the Edit function. I'm delighted that Edit still works for @XfinityJessie, but it sure would be nice if it worked for me as well, like it did for the past three years, until a few days ago.

And again, since the message still does not seem to have reached some here:

When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

Retired Employee

 • 

5.9K Messages

@BruceW I have confirmed that all notifications on the Xfinity Forum are working as designed. Any changes to how they function today would need to be added by our platform vendor. As for the session timeout message, that has nothing to do with the platform vendor or any changes they may have made. That is a required change provided to us by our Security team to ensure the forum platform remains a secure, safe environment. You will notice a similar function on other Xfinity sites/apps when logged in there after 30 minutes of inactivity. As mentioned, I have reported the editing function not working as designed to our platform vendor, once I have information to share or updates, I will be sure to share them here. 

Gold Problem Solver

 • 

25.5K Messages

... I have confirmed that all notifications on the Xfinity Forum are working as designed ...

Mine are not, unless it is by design that I do not receive any notifications for Reply messages.

@XfinityJessie: Once again, you've posted a message as a Reply, even though you've been told repeatedly that I do not receive any notice when Replies are posted. I don't understand this. Why would you post a message that you don't want me to know about???

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

Gold Problem Solver

 • 

25.5K Messages

2 months ago

It occurs to me that I may not have made clear: the Forum editor works fine for me while creating a new message. It is after that message is Posted, when I click the Edit option on the triple-dot "menu" and try to revise the message that "Failed to update" pops up and the edits I made to that existing, posted message are discarded.

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

Expert

 • 

30.3K Messages

@BruceW​ 

It occurs to me that I may not have made clear: the Forum editor works fine for me while creating a new message. It is after that message is Posted, when I click the Edit option on the triple-dot "menu" and try to revise the message that "Failed to update" pops up and the edits I made to that existing, posted message are discarded.

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

We've understood that part, Bruce.  And several of us are also having problems editing our own posts after it's been posted.  I personally think when Sprinklr added attachments, they "broke" this feature.

As for the other problem you have, there really shouldn't be any reason why you aren't getting notifications from Reply messages.  So, it has to be something either in your Profile settings or within your browser settings.  If you are @ tagged you should get a notification in email, whether it's via an @ tag in Reply or in Comment.

Sooooo....I really am trying to help here..... uncheck everything under Notifications and Preferences.  Clear your cookies and cache as well as your xfinity.com passwords [yes, you'll have to type them in again] and sign out of the Forums.  Close your browser and then restart a new session.  Log in to the Forums.  Go back to Notifications and check mark everything except Badges.  Do not click the Email and Platform buttons at top.  Sign out of the Forums.  Close your browser, then start a new session.  Reply to this post and @ tag yourself.  Sign out of the Forums.  Close your browser and start a new session and sign in to the Forums.  Then, and I know this is a lot try, when coming back here, scroll all the way down to the very bottom of the page and click on Cookie Preferences.

Let's go from here.  🙂

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Please mark an Accepted Answer!tick

Gold Problem Solver

 • 

25.5K Messages

2 months ago

... uncheck everything under Notifications and Preferences ... Go back to Notifications and check mark everything except Badges.  Do not click the Email and Platform buttons at top ...

Not sure what you're asking for here. If I uncheck everything under Notifications and Preferences and don't turn the topmost Email and Platform buttons back on, I can't check any of the boxes in those two columns.

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

Official Employee

 • 

922 Messages

Hey @BruceW, saw you testing the tags and just wanted to let you know they were coming through here if they weren't on your end. Also, unrelated to this post but wanted to let you know the cable card website should now be customer facing. Thanks for bringing it to our attention and all your help!

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Gold Problem Solver

 • 

25.5K Messages

@XfinityNicolas wrote: "... saw you testing the tags ...

Oops! Sorry about the mess! (I did clean that up, didn't I?)

I had never tried "tagging myself" as suggested above, and those posts were just throwaways intended to see if such tags (one in a Comment, one in a Reply) would generate notifications. They did not, but that's what I expected, just like I don't get and don't expect to get a notification when I post a new message.

I do get a notification if I "like" one of my own Comment posts, which has always seemed to me like a strange design decision, but that's just a small potatoes oddity compared to not getting any notification whatsoever for Replies posted by others on threads I'm subscribed to.

... wanted to let you know the cable card website should now be customer facing ...

Cool! Thank you!

Not to be picky, but when I visited the site and after I entered my account and phone numbers and clicked [Continue], a popup appeared that said:

cablecardactivation.xsp.comcast.net                                                

I am an alert box!

                                      [OK]

Well, yeah, it is, but what is it doing there? Maybe a testing leftover?

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.

(edited)

1 Message

1 month ago

And I see our attachments are no longer at the bottom of the Body.  [Edited: "Personal Information"] Removing them apparently brought the Edit function back, so it was the addition of all those files for attachments that broke the Edit feature.

(edited)

forum icon

New to the Community?

Start Here