U

Visitor

 • 

8 Messages

Fri, Jul 9, 2021 7:58 PM

Email link from homepage simply redirects back to homepage

I'm unable to view my xfinity email.  If I click the email link from xfinity.com, after briefly showing an Appsuite page I am then redirected back to the homepage.  This happens across multiple different browsers on laptop & phone(Chrome, Firefox, DuckDuckGo). A different account on the same devices is able to view webmail, just one account I am having issues displaying webmail for several days.  I can access email via a 3rd party app on phone but not on browser via webmail icon on my.xfinity.com or using link https://connect.xfinity.com/appsuite/#!!&app=io.ox/mail&folder=default0/INBOX

Any help would be appreciated.

 

Responses

Official Employee

 • 

376 Messages

3 m ago

Hi, @user_4203f0, do you ever get an error message saying anything about a server issue or something preventing the request from being completed on the website? 

Visitor

 • 

8 Messages

3 m ago

@ComcastStarr Thanks for your reply. No, I do not see any error reported. A "Welcome to Xfinity Connect" screen displays for 2 seconds and then the my.xfinity.com home screen displays again.  It's seems like the email for the account cannot be found, although the email icon shows a red number representing the number of unread emails.  Any other thoughts?

Official Employee

 • 

146 Messages

That is strange especially when it is working in the app and thank you for double checking. I'd like to take a look at the account to help find what is causing it. Can you send us a private message so I can better assist? You can send one by clicking the "message" icon in the upper right corner of our forum page. Once you click on that, input our shared handle Xfinity Support to send us a private message.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

I too am having the same problem.  This morning was ok.  Started earlier today.

Official Employee

 • 

220 Messages

Hi @user_b8071a, thank you for working hard to bring this to our attention. I can understand the frustration everyone is feeling, I am sorry this has been ongoing. We're aware of an issue and are working to fix it as soon as possible, however, we're unable to confirm a date of resolution at this time. I will keep an eye on the situation. Thanks for being a loyal Comcast customer. Your patience is greatly appreciated!   

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

2 m ago

I have the same problem for two days...main email loops back to home page... Same problem three different devices

Official Employee

 • 

154 Messages

Hi there!  Thanks so much for taking the time to reach out to Comcast here on out Community Forum to make us aware of this issue you are having.  We fully understand your frustration and are working currently to have this remedied as soon as possible.  This is being monitored and we will provide updates at the come.  If you should have any other issues please feel free to post and send us a private message any time.  

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

7 Messages

2 m ago

[Edit: Duplicate comment]

(edited)

Visitor

 • 

8 Messages

2 m ago

Thanks for letting me know others are experiencing the same issue. I am working with support and they have engaged the Advanced Repair team, but still no resolution.

Visitor

 • 

8 Messages

2 m ago

Still working with Advanced Repair Team. They have not provided a resolution yet.

Visitor

 • 

8 Messages

@user_4203f0 Please keep this thread up to date with what you're finding!!  I've got the same issue and have DM'd the support team without any response yet.  I'm unable to use another mail client because I can't get into my email settings to click the box that allows you to use 3rd party clients :-(

Official Employee

 • 

47 Messages

@user_4203f0  and @SanLeanbro  Can you both bring up incognito or private browser mode and go to xfinity.com and click the email icon? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

8 Messages

I was just able to log into webmail without private browser or incognito mode :-)

Visitor

 • 

8 Messages

@ComcastGabriel  Success!  I was able to login today and view my email via a web browser (did not require incognito mode).  This was the first time this has worked in several weeks.  Thank you for resolving the issue - it appeared to require no changes on the user side. Pass on my thanks to the Advanced Repair Team!

(edited)

Visitor

 • 

8 Messages

@ComcastGabriel How do I indicate in the forum this issue has been resolved?

Visitor

 • 

2 Messages

1 m ago

I am having this same problem! Help please; I am not sure I understand how this has been resolved for other people.

(edited)

XfinityAmir

Official Employee

 • 

6.5K Messages

Hello user_0130a7, thank you for reaching out to us here for assistance. We are more than happy to help you with getting this error cleared up, to better assist you could you please send us a private message with your full name and street address? 

 

To send a "Peer to peer" ("Private") message:
Click "Sign In" if necessary
• Click the "Peer to peer chat" icon
• Click the "New message" (pencil and paper) icon
• Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list which appears. The "Xfinity Support" graphic replaces the "To:" line
• Type your message in the text area near the bottom of the window
• Press Enter to send it

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

8 Messages

1 m ago

@user_0130a7 You will need to contact the Advanced Support Team to resolve this issue.  In my case, they needed to make a change on their side, no change was needed on the user side.  Please send a private message by clicking the Peer to Peer chat icon in the upper right corner of this forum page, click on the pen and paper icon, then enter “Xfinity Support” in the “To” section. Please include your name and address.  Hope they can help you resolve your issue.

(edited)

New to the Community?

Start Here