U

Visitor

 • 

6 Messages

Wednesday, May 24th, 2023 7:34 PM

Closed

Cannot Send Email

I cannot receive email on my account. This started Tuesday morning. I chatted with Tech Support last night but they could not solve the issue. They said I would get a call, but I never did. I have tried on iPad, iPhone, Outlook 365 and the Xfinity email web page and get the same result.
I can send in all platforms but not receive email.  Can you help?

Accepted Solution

Official Employee

 • 

864 Messages

9 months ago

Hello, @user_853f3c! Thank you for creating a new public post regarding your email concerns. We received a Direct Message from you, too, but we ask that you please only ever post your question on the most appropriate public forum board and remain patient. If needed, our team will invite you to send us a direct message. Sending unsolicited direct messages to our team, any Official Employee, or any Xfinity Forum user does violate our Xfinity Forum Guidelines and our Xfinity Forum Acceptable Use Policy.

 

Please remember, ​by having an account and utilizing these forums, you have already agreed to the rules, policies, and guidelines contained within those document as well as any other posted documents throughout the community. While we would never want to get to that point with any user, violations to those posted documents could result in a revocation of a user's Xfinity Forum posting privileges.

 

That being said, let's see what we can do to help! Are you receiving any Error Codes or Messages, by chance? If not, have you already reviewed your Email Filters and Spam Filters? We want to make sure that if you are receiving emails, they're not going to the wrong folder. Thank you for chatting with us last night! Our Digital Care Team will definitely do whatever we can to help resolve this for you.

Visitor

 • 

6 Messages

@XfinitySara​ Thanks for responding.  No, I am not receiving any error codes.  Sorry about the duplicate.  I saw another post in the forums with this problem and did what they said in the response (sent DM). 

I have checked Spam and other folders.  I can send ok, but not receive on any of the systems including webmail.

Official Employee

 • 

933 Messages

If you are not receiving email in webmail it is typically related to one of three things;


- Mail forwarding: Your mail is being forwarded to another mailbox and set to not keep a copy 

- Mail filters: A filter rule is discarding all of your emails or moving them to a folder 

- A third party client that has rules or is downloading all your mail off of our email system and keeping it locally on that device.

 

You can review your filter and forward settings in webmail > settings >> mail >>> Auto Forward AND Filter Rules 

Let me know if this helps. 

I no longer work for Comcast.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

6 Messages

Auto Forward was turned on.  It was forwarding to [Edited: "Personal Information"].  I have no idea why or who this is.  I changed my email password last night.  Should I change it again?

My husband sent me an email that came through.  Should I do anything else?

(edited)

Visitor

 • 

6 Messages

@XfinityMikeB​ I also turned off the Auto Forward and deleted the email address.

Official Employee

 • 

933 Messages

Ok good, thanks for doing that. I would recommend updating your password again just to be safe. 

I no longer work for Comcast.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

forum icon

New to the Community?

Start Here