T

Visitor

 • 

8 Messages

Mon, Dec 6, 2021 8:16 AM

Yale YRD226

Good evening!

Hey there… I am having a lot of trouble pairing Yale YRD226 electronic door lock with the Xfinity home security system.

i’ve made multiple attempts to walk through all the required steps in order to pair the lock with the security system, however in the last step, when the system is trying to pair with lock, the process fails.

I have insured that the appropriate Zigbee module is properly installed within the lock body, and the lock itself was professionally-installed and works as a standalone device. It simply won’t pair with the system and I am out of ideas.

has anyone else had a similar issue? And if so how did you solve it? 

Thanks in advance for the assistance!

Official Employee

 • 

442 Messages

1 m ago

Hi ToneStrong!

Not sure what the cause might be but I figured I would just make sure of a couple of things... can you double check to make sure the box definitely states Zigbee and not Z-Wave? The model numbers are identical but the Zigbee version must be used with Xfinity Home.

Also - are you using the Xfinity Home mobile app to attempt pairing? This is the preferred method for pairing with the system for a someone with a Touchscreen (not pairing through the Touchscreen's settings menu.)

More details in this FAQ: https://www.xfinity.com/support/articles/pair-yale-locks

Visitor

 • 

8 Messages

@XfinityBecker hello! Thank you for your response!

so it appears the locks utilize the correct Zigbee module. And yes the Xfinity home app is being used to do the pairing. We are not pairing using the touchscreen. 

Official Employee

 • 

3K Messages

1 m ago

Greetings, @ToneStrong! Thanks for reaching out to us on the Forums! I hope you are having an amazing day! I apologize to hear of the issues you are having with trying to pair your lock with the Xfinity Home security system. For further help with making sure this gets paired you may want to have a look at Pairing Yale Locks article to see if this can get you up and running. Please let us know if you still have issues afterward. 

Visitor

 • 

8 Messages

@XfinityMichaelC good afternoon!

Thanks for your reply! So I am using the very link you shared to attempt the pairing. It’s definitely not working for me. The link doesn’t have a lot of troubleshooting content so it hasn’t been too helpful for me, unfortunately. 

I'm open to suggestions!

Official Employee

 • 

210 Messages

Thanks for the update! Can you confirm the following:

 

  • Notes:
    • Your lock must have a red Yale Zigbee Network Module (AYR202-ZB-HA) version 261 or higher installed.
    • Control4 and Crestron Zigbee modules (red) are not compatible.
    • Amazon Key Zigbee modules (red) are compatible if they were installed with the Amazon Key app and then unpaired using the Lock's keypad.
    • Apple HomeKit/Bluetooth (orange) and Z-Wave (blue) modules are not compatible.
I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

8 Messages

Both locks have this module and I still don’t have the ability to connect [Edited: "Personal Information"]

(edited)

Official Employee

 • 

64 Messages

Thank you for trying those steps and letting us know it's still having an issue connecting. Where is the modem located within the home in relation to the YRD226 electronic door lock?

(edited)

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

8 Messages

@XfinityThomasA The modem is located upstairs from the locks. On the second floor. The locks are at the entry doors to the home, one floor (about 20ft vertically) below.

Visitor

 • 

2 Messages

1 m ago

hi - was there any resolution to this? I am having the exact same issue with three new yale locks. I have confirmed all of the part numbers and zigbee module numbers are compatible. Thanks!

Visitor

 • 

8 Messages

@user_9799f3 no, no resolution for me either. 😩

Visitor

 • 

2 Messages

Xfinity advanced technical support team will not help me because they say it’s a third party product. Makes no sense since it’s their app that is the issue. I also called Yale technical support and they were unable to help me because it’s not a hardware issue it is an issue with xfinity home app. When I attempt to pair the lock voice actually says “completed” but the pairing process on my iPhone times out and stated that the touchscreen is not responding. 

Official Employee

 • 

417 Messages

@user_9799f3

Hello! Thank you for going so far to receive support on this and We apologize that you are still having trouble with the Yale locks with Xfintiy Home security. Since it is a 3rd party product, we do have limited support we can provide, however, we will do all that we can still. 

A few things we can check is that the app has a current internet connection. We also ask that you check the lock manually to see if it will operate without the app. If not, try replacing the batteries. 

If you still continue to have trouble, please contact https://comca.st/33UqzkV for additional support. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

8 Messages

@user_9799f3 your issue is exactly the same as mine, as far as connection to the Xfinity app timing out. No one seems to have any solution. 

Visitor

 • 

2 Messages

1 m ago

I have the same lock and having the same exact issues. I tried through the app and touchscreen and it will not connect 😫😫😫

Official Employee

 • 

650 Messages

Hey there, @Nicole_6230, thanks for reaching out through Xfinity Forums! Sorry to hear you are also having issues with your lock! Have you tried any of the troubleshooting steps outlined on this Forums page to see if that helps resolve the issue? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

Yes I have tried every troubleshooting article found. I have also reached out to Yale for assistance. They were of no help. There has to be some type of solution for this 

Official Employee

 • 

650 Messages

Thank you so much for attempting to troubleshoot. Can you confirm the following:

 

  • Notes:
    • Your lock must have a red Yale Zigbee Network Module (AYR202-ZB-HA) version 261 or higher installed.
    • Control4 and Crestron Zigbee modules (red) are not compatible.
    • Amazon Key Zigbee modules (red) are compatible if they were installed with the Amazon Key app and then unpaired using the Lock's keypad.
    • Apple HomeKit/Bluetooth (orange) and Z-Wave (blue) modules are not compatible.
I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

8 Messages

13 d ago

Hello...do we have any other ideas from Xfinity support as to how to solve this issue? Any assistance would be much appreciated...

Official Employee

 • 

417 Messages

@ToneStrong

Thank you for all your time working on this with us. We are dedicated to troubleshooting this to get it working for you. For confirmation, can you check the keypad on the lock and see if there is a GEAR and CHECKMARK on it? Do you see any (#) or (*) icons?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New to the Community?

Start Here