Artbreak55's profile

New Poster

 • 

2 Messages

Fri, Dec 11, 2020 12:00 PM

New service

I ordered new service a month ago. An account number was issued, but no equipment or communication has happened. Customer service tells me it is pending. This seems like an extremely long time to wait without anyone touching base. The app won't give me access to my account. What can I do?

Responses

Official Employee

 • 

375 Messages

6 m ago

@Artbreak55, welcome to the Xfinity Forums. I am very sorry to hear that you have not received your equipment yet. I would love to get to the bottom of the delay.  I very much appreciate your patience and greatly apologize for the delay in our response. I know how important the services are to your home and we want to do all that we can to assist. Can you please reach out through private message with your first and last name, name on the account if different, service address and account number? If you’re having trouble locating this information, you can also reference our world-class MyAccount app to view all of your account details by the simple touch of your fingertips! Please follow the process here to learn how to obtain that information: comca.st/30x1qW2. 

BruceW

Gold Problem Solver

 • 

22.4K Messages

6 m ago


@ComcastMichele wrote: ... Please follow the process here to learn how to obtain that information: comca.st/30x1qW2. 

It isn't realistic to expect customers to recognize that the cryptic string "comca.st/30x1qW2" is actually a link. Why not post a clickable link? And why use shortened non-links when you could just as easily post the much more recognizable (and clickable!) https://www.xfinity.com/support/articles/view-account-info-my-account-app?

dcfox

Regular Contributor

 • 

329 Messages

6 m ago


@BruceW wrote:

@ComcastMichele wrote: ... Please follow the process here to learn how to obtain that information: comca.st/30x1qW2. 

It isn't realistic to expect customers to recognize that the cryptic string "comca.st/30x1qW2" is actually a link. Why not post a clickable link? And why use shortened non-links when you could just as easily post the much more recognizable (and clickable!) https://www.xfinity.com/support/articles/view-account-info-my-account-app?


I was thinking the same thing, some empoyees do provide clickable link to that. And in some post two employees post within hours saying the same thing that the other one said to contact them. The help is good but can be confusing to some. 

Official Employee

 • 

328 Messages

6 m ago

Sometimes links can post that way, but I do know where you are coming from. I like when communication is concise and easy to follow also. We are here every day working to do all we can for our valued customers. Feel free to send a private message or send follow up questions anytime. 

Official Employee

 • 

2.5K Messages

6 m ago

Hi, BruceW. It was meant to be a clickable link. We will pass your feedback along to our leadership team about the need for them to be used here. They system we use currently automatically converts them like that.

BruceW

Gold Problem Solver

 • 

22.4K Messages

6 m ago


@ComcastJosephB wrote: Sometimes links can post that way ...

If a link is preceded by "https://", the forum editor will automatically make it clickable.

 

You haven't addressed the use of URL shorteners.  What is the benefit of using them here? All they do is turn a recognizable destination into complete gibberish. "comca.st/30x1qW2"? Really? No one can have any idea where such a link leads except by following it. And since it isn't clickable, many posters will not even realize that these odd-looking strings even are links. What's the point of posting non-clickable non-recognizable links here???

 

dcfox

Regular Contributor

 • 

329 Messages

6 m ago

Its is usually clickable with other Comcast employees. It is just the one employee that it is not. Not sure why. 

 

Again

Expert

 • 

25.8K Messages

6 m ago


@dcfox wrote:

Its is usually clickable with other Comcast employees. It is just the one employee that it is not. Not sure why. 

 


It's actually several of the new OE's that are posting the shortened "un"link, and I have tried mentioning it to them in different ways to no avail.

 

@ComcastMorgan while you're at it, try getting them to tell customers how to send a PM, rather than just asking them to send the information.  And that Experts are here to help, not to be ignored.  Thanks.  😉

New to the Community?

Start Here