Babauta's profile

New Poster

 • 

1 Message

Sun, Sep 13, 2020 6:00 PM

Channel 5 NFL Football is in Spanish??

What can I do??

Responses

Regular Visitor

 • 

1 Message

7 m ago

turn off sap

JordanM

New Poster

 • 

5 Messages

7 m ago

While checking your SAP setting is a first good step, it may not be the fix.  It wasn't for me either...and only NFL games were coming in for Spanish for me as well (even though SAP was turned to "off").  After digging through the forums for like 30 minutes, I think I found the fix. I did it and haven't had any Spanish broadcast for the NFL game for like 10 mins after I did the switch.  You have to turn off "video description" in your settings.  If you have an X1 remote, hit the "B" button (above the number pad) and that should bring up your settings screen.  Scroll down to "video description" and make sure it's turned to "off".  That seemed to help me at least.  Good luck!

studolgon

Valued Contributor

 • 

376 Messages

7 m ago

Perhaps you stumbled on to the Rosetta Stone channel for learning Spanish. 🙂

New Poster

 • 

2 Messages

7 m ago

Thank you so much.  This was so frustrating. Even Xfinity Help was no help.

New Poster

 • 

1 Message

4 m ago

Thank you. This helped!!

New to the Community?

Start Here