Community Forum

modem replacement, T25

Highlighted
New Poster

modem replacement, T25

I just replaced my modem from an Arris Surfboard 300Mbps version to the T25.

I self-installed, and everything seemed to go pretty well: I'm connected, the phone works, looks like everything is in order.

However, when I go to my xfinity Status Center page, I can see 3 modems there: the old surfboard "Voice and Data Modem" with "Issues Detected" status.

I have a Voice Modem there, with "Status Unavailable"

And I have a Cable Modem there, in a connected status. The top of the page says "Looks like your modem is not responding"

I guess long story short: how do I force the system to drop the old modem? That seems to mess things up here. The reason I bought the T25 is to go gigabit. I don't want to initiate that process until everything looks good on the account.

I called xfinity support yesterday, the guy said try to give it time. Now a day later, no change.

Any ideas?

Highlighted
New Poster

Re: modem replacement, T25

Nobody had this issue before?

Expert

Re: modem replacement, T25


@totya wrote:

Nobody had this issue before?


I have, several times. It's taken anywhere from a couple of days to two weeks for the account to properly reflect the changes. However, it made no difference to my service and my modem, gateway, or whatever was the active device functioned properly the whole time. 

In short, if your service is fine, then you don't need to worry about it. If you want to upgrade your speed, go on ahead. 


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: modem replacement, T25

I’ve been going through the same issue. Xfinifty is no help. I think there’s an issue with the T25 syncing with the Xfinifty’s “my account” app. It has been 3 months now, with nothing but issues since the T25. I think I’m switching to a netgear router.
Highlighted
Expert

Re: modem replacement, T25


@CTam wrote:
I’ve been going through the same issue. Xfinifty is no help. I think there’s an issue with the T25 syncing with the Xfinifty’s “my account” app. It has been 3 months now, with nothing but issues since the T25. I think I’m switching to a netgear router.

Please post your issue in a new thread as this is unrelateed to the topic at hand. 

As OP has not responded in over a month, this thread is closed. 


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!