Community Forum

Slow Gigabit Speeds Continued

Highlighted
Frequent Visitor

Slow Gigabit Speeds Continued

aThis is a continuation post from a previous post because for some reason i am no longer able to comment on the previous post of mine. https://forums.xfinity.com/t5/Your-Home-Network/Slow-Gigabit-Speeds/td-p/3287046 I had the Blast internet and was getting wifi speeds of 150-200 Mbps and ethernet connected speeds of 240+Mbps. I upgraded to Gigabit and am recieving wifi speeds of 50Mbps if i'm lucky and wired speeds of 150Mbps. I have a Nighthawk C7800 Modem Router Purchased in August of this year. I have a GearHead membership and no one can figure out why i am having slow internet. I have had multiple comcast technicians come out, (I'm up to 5), the cables inside of my home have been rreplaced, a technician came out and replaced the cables outside of my home. I have spent 26 HOURS on trying to get the speeds that i am paying for. I have been given excuses from comcast including but not limited to, "Oh your Nighthawk cant support the gigabit connection" to "Well we are testing them from over the phone and you are getting 940Mbps so its on your end". I am so fed up with this service and the countless time I have wasted trying to figure this out. I replaced my modem Router 3 times, modified my router with GearHead to be able to do what it needs to do to get the speeds, replaced the cables inside and outside of my home, and spoke with comcast too many times. I am now turning to the forums and the community for some help. Please help. I have since had multiple comcast reps come out and i was in discussion with a comcast rep online who said things would be resolved by september and I havent heard from them in over 10 days now. NOT SURE WHERE THE DISCONNECT IS HERE. I am irate and this is completely unacceptable. I was told it was told by a comcast rep that the issue was a Packet loss bit error rate fail (confirming that the issue is on comcasts end). That was a month ago and they have done nothing about it. Ive reached out to the online rep a few times after not hearing anything and nothing.

Highlighted
New Poster

Re: Slow Gigabit Speeds Continued

Yup. <Edited> I just called in and downgraded so Im not paying 1gB premium for no gain (250Mpbs download average/ 1.5Mbps upload average and I was paying for 1,000Mbps DL/ 25Mbps UL). Im continuing to troublstoot myself. Ive had 2 techs to the house and nada.......

Highlighted
Frequent Visitor

Re: Slow Gigabit Speeds Continued

I wish I was getting 250. Since the original post ive been getting 60-70 mbps down. If you gifure out a solution please post it as comcast is not being very helpful. I do have one tech who is committed to getting this rresolved which makes me feel better about the situation but the fact that ive been dealing with this for 13 months doesnt make me feel so good. Best of Luck!