Community Forum

Re: Switching back to Comcast after 1.5 years.

Highlighted
Contributor

Re: Switching back to Comcast after 1.5 years.

I have comcast preium tv with blast interent and i give this service a 5 out of 10.  I sometimes get 117 down and then just 5 houirs later it goes to 32.  It goes up and down like a yo yo.  The tv guide is so sluggist it is about 10 to 13 seconds before it responds to any input.  The preium / on demand content is going away fast.  on the 10th starz , cinemax and i believe one othe is going away.   Disney just recently removed the on demand FX channel.  History channel vault removed shows that people were watching.  Not much of an improvement to att of then the speed when it works , oh i still pay over 100 dollars a month for this experience.  When i had att uverse at least if was the same speed all the time.

Highlighted
Valued Contributor

Re: Switching back to Comcast after 1.5 years.


@JMy1 wrote:

I have comcast preium tv with blast interent and i give this service a 5 out of 10.  I sometimes get 117 down and then just 5 houirs later it goes to 32.  It goes up and down like a yo yo.  The tv guide is so sluggist it is about 10 to 13 seconds before it responds to any input. 


That's not normal.  You should have a tech out to fix your performance.

Highlighted
Expert

Re: Switching back to Comcast after 1.5 years.


@JMy1 wrote:

I have comcast preium tv with blast interent and i give this service a 5 out of 10.  I sometimes get 117 down and then just 5 houirs later it goes to 32.  It goes up and down like a yo yo.  The tv guide is so sluggist it is about 10 to 13 seconds before it responds to any input.  The preium / on demand content is going away fast.  on the 10th starz , cinemax and i believe one othe is going away.   Disney just recently removed the on demand FX channel.  History channel vault removed shows that people were watching.  Not much of an improvement to att of then the speed when it works , oh i still pay over 100 dollars a month for this experience.  When i had att uverse at least if was the same speed all the time.


Start here;


https://forums.xfinity.com/t5/Your-Home-Network/Connection-Troubleshooting-Tips/m-p/1253575#M94474

 

Post the requested info from here;


https://forums.xfinity.com/t5/Your-Home-Network/Information-Requested-for-Connection-Related-Posts/m...



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!