Community Forum

Paying for Gigabit but Daily Drops to 30 Meg

KatTheFoxtaur
Frequent Visitor

Paying for Gigabit but Daily Drops to 30 Meg

I've had the Gigabit tier service since moving to my new apartment in April, 2020. Generally, I get just under 900mbps down, and about 42 mbps up.

 

Every day (or more), I have a "slowdown", where my speeds (BOTH upload and download) drop to about 25-32mbps. The only solution is a modem reboot. I am a network technician for a prestigious college, so I know my way around a network and troubleshooting steps. "Have you tried ____?" Yes, yes I have tried that already.

 

My physical setup is as follows:

 

8-way tap block on utility pole → Xfinity demarc → 8-way amplifier → modem → router → network

 

 

My router is a Dell PowerEdge 1950 III running a Linux-based system called "pfsense". Before everyone jumps to the conclusion it must be that, I have already tried using my Negear NightHawk X6 R8000 router, which provides the same results. I can run the "speedtest" command, which I'll attach at the end. Same results.

 

My modem is a Netgear NightHawk CM1150V (yes I need the telephony modem, as I have two telephone lines). "Oh this sounds like a modem issue", well I already tried that. It's less than 3 months old, so I was able to get a warranty replacement CM1150V. Same results.

 

"Well what about that amplifier?" I have tried both the amplified and non-amplified ports. Amplified port gives me power ratings somewhere around +8dBmV for all downstream channels. The non-amplified ("VoIP") port (which I am currently using in the attached screenshots) gets between +0.2 to +3.7dBmV depending on the channel.

 

 

"What about your Wi-Fi?" I am using hardwired connections. The result is the same even from the "router" itself. My wired network is as follows:

 

Modem → pfsense server via two 1gbps copper Ethernet (using 802.3ad LACP - and yes, I get the same results with LACP disabled, as well as from the Netgear router, which does not support LACP, so I've ruled out LACP as a cause).

pfsense server → Cisco main network switch via 1gbps fiber

Cisco main switch → Cisco local switch via 10gbps fiber

Cisco local switch → desktop PC

 

Again, same results occur with LACP disabled and running the test directly from the pfsense server.

 

"Well maybe it's your cabling" I've proven that not to be the case. I ran all the interior connections myself, and have two separate feeds from the amplifier to the server room. Using either feed produces the same results (and the same signal tests, etc., and of course I have tried both feeds using both the amplified and the non-amplified port). I also have a Sadelco cable TV signal tester, which shows the signal strength on digital/analog cable TV lines. The signals were beautiful.

 

From the amplifier in the basement, I ended up running a new coax between the demarc and the input. Same results.


A Comcast technician came out to my place and he ran some sort of "new" test (according to him) where he can run signal/cable test against my modem and it responds to his equipment. He said it can even tell when a coax cable had been bent 90° and bent back in the past. It also shows fluctuations in the signals. He said it was perfect, and was impressed by my cabling.

 

I asked the technician if he would please run a new drop from the tap block. We use the same hardline tap blocks where I work inside wiring closets, and I know they can sometimes have issues. He used a different port on the tap block, connected a new PoE filter, ran a brand new RG6 down to the demarc, and connected it to a different coupler inside the demarcation box. Same results.

 

At this point, everything between the output from the tap block on the pole all the way to a different modem and different router, has been swapped out. It's not my equipment, it's not my wiring. I have now proven this to be the case, that the issue must exist upstream of the tap block.

 

I would prefer Comcast doesn't waste my time, and would please PROVE to me if they try to say there are no issues on their end. Because at the end of the day, I am paying for gigabit service, and I am getting 30 megs. There's obviously an issue, and I've ruled out every single piece of equipment and wiring on my side of that equation.

 

 

Attached info:

 

Current speed test, 2020-08-02:

https://www.speedtest.net/result/9850741844

 

My usual speed test, after rebooting the modem:

https://www.speedtest.net/result/9846811509

 

Current speed test from pfsense:

https://www.dropbox.com/s/s2shepv01ukpel3/2020-08-02%2012_09_59-%20pfsense%20-%20Diagnostics_%20Comm...

 

 

Cable modem event log - the two "Time not established" and the three events above it are always at the time I reboot the modem. There are never any new events between the reboot - at which point everything is working fine for a while, but you see the new events then - and the slowdown. The 3-5 events are always right after rebooting.

https://www.dropbox.com/s/tgi7qdgic4d5eqm/2020-08-02%2012_16_26-NETGEAR%20Modem%20eMTA%20CM1150V.png...

 

I do also get these errors sometimes:

https://www.dropbox.com/s/xg827x3p7h8znkh/2020-08-02%2012_25_24-NETGEAR%20Modem%20eMTA%20CM1150V.png...

 

And of course, the signal page (un-cropped, since it squeezes it onto a smaller iframe...):

https://www.dropbox.com/s/vtrnpw9r6sytmf6/Screenshot_2020-08-02%20NETGEAR%20Modem%20eMTA%20CM1150V.p...

 

If someone from Comcast can actually check and PROVE whether or not the equipment upstream from my demarcation point is having issues, I would really appreciate that. I've seen forum posts from people with the same issues as mine, some were never resolved, and one I recall, they were told it was their modem, they replaced the modem three times, and after several months of this, Comcast ultimately found out there was an issue with some node upstream from the customer, replaced the node, and the customer's issues went away. I would really not like to play the blame game here. I've proven beyond a reasonable doubt that it's not my equipment. I would now like Comcast to do the same.

 

If anyone else has had this issue, and you have gotten it resolved, PLEASE let me know what you did! I see "Closed" topics on this where people never say what the root cause ultimately was...

 

Thank you,

~Kat

KatTheFoxtaur
Frequent Visitor

Re: Paying for Gigabit but Daily Drops to 30 Meg

Does anyone at Comcast have a clue?

 

Have any fellow customers here experienced a similar issue?

KatTheFoxtaur
Frequent Visitor

Re: Paying for Gigabit but Daily Drops to 30 Meg

Just visited my parents on Cape Cod, they also have Comcast, with the 400mbps service. Their internet speedtests were just as bad as mine before I reboot.

 

Comcast sent a tech, she tried to blame my network setup, but I explained repeatedly that I got the same results when using a Netgear router, and before I set up any of my equipment. I even tried putting the Netgear router back in place, using only it and the modem, and the same issues occur. It's not my setup.

 

She did ask me to forward the logs I've been getting on the modem. Still no word on the results, 2 weeks later.

KatTheFoxtaur
Frequent Visitor

Re: Internet is slow until I restart my modem..

Did you ever get a resolution to this? I have the exact same issue - paying for gigabit service (~980 down, 40 up; I get just under 900 down and 42 up normally) - yet when I get these slowdowns, 30 megs in each direction. Speedtests seem jittery, leading me to believe there's a lot of packet loss. Ping times are high too.

justsam
Contributor

Re: Internet is slow until I restart my modem..

First, I have no answer to your issue, nor does Comcast it appears.  Seems like Comcast should have a way of proving to customers, that at the demarc, the service is as promised.  Realizing that issues can be intermittent, some form of recording monitor should be available, unless of course you are afraid of what would be revealed.  Seems like it would benefit both customer and Comcast especially for their premium service customers who really do not want to hear "have you checked your connections?"

KatTheFoxtaur
Frequent Visitor

Re: Internet is slow until I restart my modem..

My previous post was actually in reply to a different thread, but somehow it made it onto this one. Of course, it would be nice if these forums didn't put the reply section on a different page....

 

@justsamSeems nobody does, as I've seen several similar threads that never have a resolution. When the tech came, she was unable to get her tester to connect via Ethernet through my modem, and couldn't explain it. She indicated that, when connecting it directly via coax, it was fine. But so is my modem, once it's been reset.

 

It would be nice to know whether her tester has the same issue as me after several hours. Or, maybe it's a glitch, sync issue, etc., or even something that's specific to my modem firmware (of course, Comcast is responsible for the modem firmware, including third-party modems).

 

I'm not sure how I would really be able to monitor this properly - the modem logs don't indicate any issues between it working and when it slows down, just issues at the time of reboot (at which point it's working). Other than that, it's only a slowdown. I'm not seeing any packet losses, just higher latency and much slower bandwidth. There are no uncorrectables or other such signal issues apparent in the modem.

KatTheFoxtaur
Frequent Visitor

Re: Internet is slow until I restart my modem..

The issue turned out to be a known bug in the Netgear CM1150V modem firmware v2.02.04: When 802.3ad LACP is used, a firmware bug can cause the WAN connection to slow to around 25-30mbps until it is rebooted.

 

Netgear released to Comcast a firmware update that adresses this but over a year and a half ago, but it's Comcast's responsibility to push the firmware to the modem. Comcast has still not yet released the new firmware for some reason; their current version is still v2.02.04.

 

Until Comcast gets their act together and pushes the updated firmware, the solution is to disable the use of LACP on the modem and attached equipment. I have done so, and have not had the slowdown since.

 

~Kat