Community Forum

Only one Ethernet port is working on the XB7 modem in Bridge Mode

Highlighted
Frequent Visitor

Only one Ethernet port is working on the XB7 modem in Bridge Mode

Good morning.  I have the new XB7 running in bridge mode.  My Orbi RBK752 is plugged into the 1st Ethernet port.  When I plug my Netgear 24 port switch (JGS524NA) which runs my gaming and streaming PS into tyhe 2nd port I get an Unidentified network on both PC's as well as an odd IP address.  I have no internet on any of the PC's attached to the switch.  When I attach the switch to the ORBI it works fine.  I can attach my streaming laptop to the XB7 direct through port 2 and it works fine.  Any help would be appreciated.  Thank You

 

 

Highlighted
Expert

Re: Only one Ethernet port is working on the XB7 modem in Bridge Mode

When in Bridge Mode, only 1 port will work.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Silver Problem Solver

Re: Only one Ethernet port is working on the XB7 modem in Bridge Mode

When in bridge mode, the internal router is bypassed, so it acts just like a standard modem. Most modems only have one port. Extra ports might work if you are allowed mulitple IP addresses, but outside of business accounts, that is hard to impossible to get now.

Highlighted
Expert

Re: Only one Ethernet port is working on the XB7 modem in Bridge Mode


@jweaver0312 wrote:
When in Bridge Mode, only 1 port will work.

In bridge mode you need a stand-alone router to be connected to port number 1 on it and to use the ports on the stand-alone router.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Only one Ethernet port is working on the XB7 modem in Bridge Mode

Thanks for the help.  Makes sense.  The sales manager at Comcast and the phone support both said that it should allow all the ports on the back to work.