Community Forum

iPhone calls go straight to voicemail

Highlighted
Regular Visitor

iPhone calls go straight to voicemail

Husband and I both have XR iPhones. Our calls seem to be going straight to Voicemail. We do not know why. Do not Disturb completely off. WiFi and Cellular on. He calls. I let in ring. I swipe and get a beep-beep noise but no call. He goes straight to voicemail when he calls me. Same with everyone who tries call either of us. We are baffled. Both phones worked fine when we first got them in January. Now neither one of us get any calls from anyone. The calls just go to voicemail no matter if the phone rings once or three times or whatever. Or a "fail"?

Highlighted
Regular Contributor

Re: iPhone calls go straight to voicemail

Turn off wifi on both phones.   Retest.

Reboot both phones.   Retest. 

Turn on wifi on both phones.   Retest.  

Disable wifi-calling on both devices.   Retest.

Reboot.  Retest.

 

After maybe considering/trying the above stuff,  consider to verify that both phones are upgraded to latest IOS 13 before attempting to re-enable wifi-calling.  

Highlighted
Contributor

Re: iPhone calls go straight to voicemail

Also make sure the 'Silence Unknown Callers' toggle is off under Settings, Phone

Highlighted
New Poster

Re: iPhone calls go straight to voicemail

I am having this problem also, again. I had this problem last year and spent 1.5 hours troubleshooting with Xfinity. Got to the point where they said to reinstall my OS to which I replied "no way".

 

She did a lot of searching and came up with the solution as follows:

 > Enter *73 -> then hit the call button.

> Phone will dial, get received and then get hang up 

 

This sets something in the cellular routing and it fixed my problem (again today). The tech today listened to my story about last year and after quick search on thier KB, reminded me of this solution. I'm going to put this in notes on my phone for next time.

 

Highlighted
Official Employee

Re: iPhone calls go straight to voicemail

Hello everyone,


Thanks for your support and for initiating and continuing conversations by providing helpful information.


Along with making sure that Do Not Disturb is toggled off, or that it is not on a schedule such as Bedtime, like MEGEDH mentioned, under the Settings>Phone options, make sure that Call Forwarding is toggled off along with Silence Unknown Callers, and Blocked Contacts.


Also, if you’ve downloaded a 3rd party app to help you manage spam phone calls, investigate the settings on that app to make sure it is not blocking numbers that it shouldn’t.


Chris


P.S. In case your post has gone unaddressed, please note that you can always reach out directly to any Official Comcast Employee by clicking on the employee name and from the profile page select the blue ‘send a message’ button.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Official Employee

Re: iPhone calls go straight to voicemail

Hey everyone,

 

I wanted to pass along some information that was provided to me by @DaveO3 in where phone calls can/do route automatically to voicemail when connected to a 2G or 3G signal while using data.  This applies to VoLTE enabled devices as well.  

 

Thanks again for the info DaveO3!

 

Chris 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: iPhone calls go straight to voicemail

My phone is up to date, I've restarted it. , tried the *73 thing and it still goes directly to comcast voicemail when I call home. I've turned off the call forwarding and it works fine. Turn it back on and the problem is still there. It just started Friday 7/10. What's changed and how do I correct it?