Community Forum

WiFi Calling Not Working

Highlighted
Frequent Visitor

Re: WiFi Calling Not Working

Did you complete job the emergency address?
Highlighted
New Poster

Re: WiFi Calling Not Working

I am having exactly same problem with enable WiFi calling after switch from Verizon to Xfinity
Highlighted
New Poster

Re: WiFi Calling Not Working

I am having exact same issue with a brand new iPhone 11
Highlighted
New Poster

Re: WiFi Calling Not Working

I had the issue today after moving from TMO to XFINITY and chat was not any help. Came across this forum and tried matching my emergency address to my Xfinity account and it works now. I did a network reset before though.
Highlighted
Frequent Visitor

Re: WiFi Calling Not Working

FWIW: I only see wi-fi calling icon when I use a bluetooth earpiece.
Highlighted
New Poster

Re: WiFi Calling Not Working

I tried entering my previous address with Xfinity into the WiFi calling 911 page and it worked. I now have  WiFi calling on my iPhone after a frustrating week trying everything else that an Xfinity tech suggested. Now I have to figure how and why this ancient address still lives in my Xfinity file, but that’s a fix for another day.

Highlighted
New Poster

Re: WiFi Calling Not Working

Possible solution!

This was happening to me as well. On my previous phone I had entered the address. Changed/upgraded phones (to one bought from xfinity) And I kept getting the same loop you are. I’d turn it on. No address taken, I’d get the “contact xfinity mobile error”. When I clicked the “ok” button on the error, it would appear that WiFi calling was on but when I backed out and returned, it was off.
But then I made one change which seemed to work. I had been signed in to a generic xfinity wifi hotspot, not the one through my router. When I changed it back to “my” hotspot, it accepted the address and turned it on!
Highlighted
New Poster

Re: WiFi Calling Not Working

Had the same issue.  Xfinity and Apple support no help  Here's what fixed the issue for me (iPhone X BYOD coming from AT&T):

Under Settings, go to Wi-Fi, then under Ask to Join Networks, select Notify (other choices are Off and Ask).  Then go to Cellular, xfinity mobile, make sure Wi-Fi Calling is set to On.  At this point, you should be able to enter your emergency address. Once you enter and confirm, my Wi-Fi calling remained set to on (previously it reverted to Off). I think the trick (for me) was making sure the Join Networks setting under Wi-Fi was set to Notify (and not off). Since doing this my Wi-Fi calling has remained on with no issues.  

BTW, thanks for nothing xFinity and Apple support.

Highlighted
New Poster

PROBLEM SOLVED--Re: WiFi Calling Not Working

Settings

  Wi-Fi

     Ask to Join Networks

       Notify

   

Setting

   Wi-Fi

      Auto-Join Hotspot

        Automatic

 

Changing these 2 settings allowed me to enter my emergency address (after turning Wi-Fi Calling On) and the Wi-Calling remained on (instead of reverting back to off).