Community Forum

Why does my Xfinity service keep disconnecting?

Highlighted
New Poster

Why does my Xfinity service keep disconnecting?

I recently switched to Xfinity mobile with an unlocked AT&T iPhone X. It seems like during my commute, as I travel through different cities, my service disconnects and won't reconnect without me enabling airplane mode and disabling. I've talked to the folks at the store and they changed my sim card and still have issues. I took the phone to Apple and did a full restore and showed it was unlocked in iTunes and still same problem. This issue happens with my phone and my wife's phone as well. I've also reset the network settings. This is driving me crazy and I may have to go back to AT&T 😞

Highlighted
Official Employee

Re: Why does my Xfinity service keep disconnecting?

Hello mobileph1,

 

I appreciate you taking the time to reach out and I’m sorry to hear you and your wife are both experiencing issues with your Xfinity Mobile service. 

 

I also appreciate the troubleshooting steps you’ve already taken, and I’d love the opportunity to work with you further to find a resolution for you both. 

 

Please reach out to me via private message.  Click on my name ComcastJaredB and from the profile page click on the blue ‘send a message’ button.  In your private reply please include the following information so that I may authenticate and access the account;

First and last name, mobile number, complete service address, and the last 4 digits of the pay method on file.

 

Finally, please include the IMEI for both your devices.

 

Thank you again for time and patience.

Jared


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Why does my Xfinity service keep disconnecting?

@ComcastJaredB 

 

I"m having this exact same issue. I tried to follow your instructions to submit a private reply but couldn't find the button to do so. any help would be appreciated.

 

Thanks