Community Forum

Re: Xfinity stream app does not work

Highlighted
Valued Contributor

Re: Xfinity stream app does not work

Our one and only mobile android device (Tablet) is working fine with everything available on the Xfinity Stream app via Wifi.  

 

However, just recently our ethernet connected Windows PC (w/Firefox browser plus the latest Flash on our 1Gig HSI Tier) has started to generate a "Try Again" message each time we try to view Live, OnDemand, or Clould DVR content using our PC via the Online Xfinity Portal ... (Except for NBC TVGO, which strangely continues to works fine Live) .

 

Here is message now poping up on our ethernet connected PC (except for NBC TVGO Live as mentioned above):

 

                              "It looks like your device is offline"

"Once your Internet connection is restored, your video will resume automatically."

                                            "Try Again"

Have tried things with all 4 of our existing user account names, plus tried the "create a new account suggestion" offered previously in another thread by @Rustyben to no avail.  FWIW, we've had the same default username and 3 secondary accounts for the last 17 or 18 years. Also rebooted our Cable Modem and Router.

 

Not sure if I've posted in the right place ... Is this known recent issue?

Expert

Re: Xfinity stream app does not work


@eecon1 wrote:

My mobile android device is working fine with everything available on the Xfinity Stream app.  

 

However, just recently my Windows PC (w/Firefox browser plus the latest Flash) over at the Xfinity App Portal website has started to generate the following message each time I try to view Live, OnDemand, or Clould DVR content ... except for one channel (NBC, which strangely continues to works fine Live via TVGO).  I receive the following message:

 

                              "It looks like your device is offline"

"Once your Internet connection is restored, your video will resume automatically."

                                            "Try Again"

I tried it with all 4 of my existing user account names, plus tried the "create a new account suggestion" offered previously within this thread by @Rustyben to no avail.  FWIW, I've had the same default username and 3 secondary accounts for the last 17 or 18 years.

 

Not sure if I've posted in the right place ... Is this known recent issue?


promoted your post to a separate thread as previous is a different issue. the online/offline is a different situation.  when you have the problem, is it while connected to your own home wifi? cell data? to a different wifi? did you try accessing the the using a different smart phone/tablet, or a desk/laptop?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Valued Contributor

Re: Xfinity stream app does not work


@Rustyben wrote:

Not sure if I've posted in the right place ... Is this known recent issue?

promoted your post to a separate thread as previous is a different issue. the online/offline is a different situation.  when you have the problem, is it while connected to your own home wifi? cell data? to a different wifi? did you try accessing the the using a different smart phone/tablet, or a desk/laptop?


Thanks @Rustyben .... Using your suggestions above and by process of elimination we can quickly rule out the following:

 

1. Home Wifi because the PC is Cat6 ethernet connected to our 1Gig service;

2. Cell Data because my wife and I do not use Smartphones;

3. Different Wifi because our PC does not connect via Wifi as mentioned above;

4. Different Smartphone/Tablet because our one and only wireless device (Android Tablet) works fine;

 

That seems to leave testing a different PC via ethernet on our 1Gig service (which, until recently worked fine at the Xfinty Stream Portal and curiously still works on NBC TVGO Live).

 

I suppose we could try to drive down our snow covered icy road in the hopes of convincing a neighbor to loan us their PC for testing .... unless there are any other safer suggestions we might first try?

 

Thanks again.

 

Expert

Re: Xfinity stream app does not work


@eecon1 wrote:

@Rustyben wrote:

Not sure if I've posted in the right place ... Is this known recent issue?

promoted your post to a separate thread as previous is a different issue. the online/offline is a different situation.  when you have the problem, is it while connected to your own home wifi? cell data? to a different wifi? did you try accessing the the using a different smart phone/tablet, or a desk/laptop?


Thanks @Rustyben .... Using your suggestions above and by process of elimination we can quickly rule out the following:

 

1. Home Wifi because the PC is Cat6 ethernet connected to our 1Gig service;

2. Cell Data because my wife and I do not use Smartphones;

3. Different Wifi because our PC does not connect via Wifi as mentioned above;

4. Different Smartphone/Tablet because our one and only wireless device (Android Tablet) works fine;

 

That seems to leave testing a different PC via ethernet on our 1Gig service (which, until recently worked fine at the Xfinty Stream Portal and curiously still works on NBC TVGO Live).

 

I suppose we could try to drive down our snow covered icy road in the hopes of convincing a neighbor to loan us their PC for testing .... unless there are any other safer suggestions we might first try?

 

Thanks again.


since your android is working then the original post/thread had to be moved now to streaming website area of the forum. you mentioned the firefox browser. could you try streaming using the chrome browser (latest update)? Chrome includes a built-in sandboxed flash and works well with Xfinity. if you have chrome installed and it is not working, what messages are you seeing on the screen? do you run your PC on a VPN? did you change the default DNS servers to non-Comcast DNS servers? Some extensions to browsers can actually cause sites to be blocked. 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Valued Contributor

Re: Xfinity Stream Website now Works - Thanks!


@Rustyben wrote:


since your android is working then the original post/thread had to be moved now to streaming website area of the forum. you mentioned the firefox browser. could you try streaming using the chrome browser (latest update)? Chrome includes a built-in sandboxed flash and works well with Xfinity. if you have chrome installed and it is not working, what messages are you seeing on the screen? do you run your PC on a VPN? did you change the default DNS servers to non-Comcast DNS servers? Some extensions to browsers can actually cause sites to be blocked. 


Good Deal Thanks! @Rustyben .... It's now working again okay.  DNS Servers were set for 75.75.75.75 and 75.75.75.76 (which I believe are Comcast), but on a lark I reset to assign DNS Server Automatically.   After that, our FF bookmark for the Xfinity Streaming Website Portal redirected to another page (rather than directly to "Listings" like before).  The redirected page showed FF was outdated (by 6 months ... was using FF 67 and needed FF68+).   Updated FF to 72 and the PC is Streaming once again!  Many Thanks.