Community Forum

x1 box stuck on the welcome screen

Highlighted
New Poster

x1 box stuck on the welcome screen

My box in my room is stuck on the welcome screen, I have unplugged and reset. It won't go past that screen. Do anyone know how to fix this problem?

Highlighted
Official Employee

Re: x1 box stuck on the welcome screen

Hello Crawford51. Thank you for joining the Xfinity Forums and for creating your first post. I can assist with troubleshooting your X1 box issue. To get started, please send me a private message and include your full name so I can assist you. You can click my name (ComcastJoeTru) to view my profile and send me a private message. Click "Send a private message" and private message me.



I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: x1 box stuck on the welcome screen

I'm having the same problem. Re- booted several times as well as re -booting my gateway. Issue will not go away. I have 2 X1 boxes,one works and the other one is stuck at Welcome. Any ideas?

Highlighted
New Poster

Re: x1 box stuck on the welcome screen

Mine is also stuck on the Welcome Screen.  Also doesn't appear to recognize the Voice Remote.  I've tried A&D to unpair and various other pair options.  Stuck on pop-up about unpairing remote but no way to get to the OK button.

 

This box is unlike the others in my house.  All the others connect via coax, this one is just connected via the wifi.

Highlighted
Silver Problem Solver

Re: x1 box stuck on the welcome screen

I had luck with the System Refresh:

 

https://www.xfinity.com/support/repair/tv/


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
Expert

Re: x1 box stuck on the welcome screen


@azbmiller wrote:

Mine is also stuck on the Welcome Screen.  Also doesn't appear to recognize the Voice Remote.  I've tried A&D to unpair and various other pair options.  Stuck on pop-up about unpairing remote but no way to get to the OK button.

 

This box is unlike the others in my house.  All the others connect via coax, this one is just connected via the wifi.


is it an xr11 or xr15 remote?  note that sometimes when firmware is updated, and your remote flashes red/green when you press a button you just unplug the set top box (or do the system reset) and then the remote will be 'known' again. it seems that sometimes the set top box does not properly load the configuration files for the connected-by-rf remotes.  working after the reboot or system reset?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!