Community Forum

voice

Highlighted
New Poster

voice

phillies channel is spanish instead of english

 

Highlighted
Expert

Re: voice


@ldukea35 wrote:

phillies channel is spanish instead of english

 


press the down button on the xfinity remote then left to 'SAP' and hit ok to turn off check box.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!