Community Forum

channels in Spanish and commercials in English

Highlighted
New Poster

channels in Spanish and commercials in English

I had the problem starting with the big game on Sunday night on Fox 1016. It continued on other movie channels. I tried everything the comcast agents recommended and nothing worked. Finally I found the solution. On your comast remote  push the large letter B (next to A. Under accessibility settings make sure the video description is set to OFF (it reverts to Spanish if it is on).

 

Highlighted
Frequent Visitor

Re: channels in Spanish and commercials in English

Thank you! I had the same problem. This fixed it. Too bad I didn't know this on Sunday