Community Forum

XiD-P TV box not working after replacing Xfinity router with Netgear cable modem

jillyfish924
New Poster

XiD-P TV box not working after replacing Xfinity router with Netgear cable modem

Hi there! Apologies for the long post. I've searched these forums for answers, but I can't quite find a scenario that matches mine.

 

I have an X1 Double-Play internet/TV package. Initially, it was professionally installed by an Xfinity technician. Internet connectivity to Comcast and in-home WiFi was handled by an Xfinity supplied Technicolor CGM4140COM voice and data modem. Cable TV box service is provided by an Xfinity supplied Pace XiD-P (PXD01ANI).

 

The coxial cabling was installed as follows:

  • Wall outlet -> 2-way coaxial splitter:in
    • 2-way splitter out:1 -> Technicolor router coaxial
    • 2-way splitter out:2 -> Pace XiD-P TV box coaxial in

 

I recently replaced the Xfinity supplied router with a Netgear CM1000 cable modem and Netgear Orbi wireless mesh system. The cable modem is approved by Comcast to support my service (referencing mydeviceinfo.xfinity.com). My internet and wireless services are activated and working normally.

 

The coaxial cabling is unchanged from the Xfinity technician's installation with the exception of the Netgear cable modem replacing the Technicolor router:

  • Wall outlet -> 2-way coaxial splitter:in
    • 2-way splitter out:1 -> Netgear cable modem coaxial
    • 2-way splitter out:2 -> Pace XiD-P TV box coaxial in

 

However, the Pace XiD-P TV box can no longer connect. The TV is displaying "Sorry, we're having some trouble. Please tighten your cable connection then restart your TV Box, which can often fix common issues." There is also a code "RDK-03036" in the bottom right of the screen. I've tried tightening all of the connections, restarting the TV Box, remotely resetting the device using Xfinity's website, re-establishing the cable modem's connectivity, and contacting Xfinity support for assistance. I'm still getting the same error.

 

What am I missing? Is the XiD-P capable of working in this configuation? There is no other Xfinity equipment installed in my home and I've read that the XiD-P is a companion device that requires another device with a tuner installed for connectivity to Comcast's cable services.

 

Any assistance will be greatly appreciated. Thanks.

CCAndrew
Diamond Problem Solver

Re: XiD-P TV box not working after replacing Xfinity router with Netgear cable modem

The new modem works for your internet service (like you posted)but only a compatible gateway is going to work with the XiD. You may be able to swap out for an XG2 that doesn’t require the gateway.

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
jillyfish924
New Poster

Re: XiD-P TV box not working after replacing Xfinity router with Netgear cable modem

Thanks for the quick reply, @CCAndrew. So I'm guessing I'll need something like the Pace XG2 which has it's own tuner(s) to get cable service? (Referencing X1 TV Box Comparison - DVR vs. Non-DVR)

jillyfish924
New Poster

Re: XiD-P TV box not working after replacing Xfinity router with Netgear cable modem

Just re-read your reply and I now see your mention of the XG2. Thanks again @CCAndrew.