Community Forum

Xg2v2 not displaying @4k on new tv.

Highlighted
Frequent Visitor

Xg2v2 not displaying @4k on new tv.

Hello, hopefully this post finds everyone healthy despite the current worldwide pandemic...

So I bought a new LG nanocell TV (65NANO90UNA) and when I connected it to my box (XG2v2) via my home theater (Yamaha TSR-7810), which is a 4k compatible reciever and using 4k compliant HDMI cables, I do not get the option of displaying in 4k. I've done hard resets on the tv and cable box via unplugging, as well as getting on the connect app and doing a system refresh, and I still get no option to pick 4k. I even got creative enough to pull up the display page on the cable box and pull up the info pane on the tv since they don't overlap each other in case my alcohol impared fingers typed the wrong model numbers.

Edit: I just noticed looking over my post that the cable box even recognizes the tv as uhd 4k compliant but won't display anything other than HD.
20200503_225305.jpg
Highlighted
Diamond Problem Solver

Re: Xg2v2 not displaying @4k on new tv.

It’s probably because the XG2 isn’t capable of displaying anything in 4K. You need either a XG1V4 or Xi6

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
Frequent Visitor

Re: Xg2v2 not displaying @4k on new tv.

thank you sir. I assumed (and we all know what that means) that the 2v2 was the newer version of the 1vX