Community Forum

XG1v4 DVR Still Shows Old Device Name After Renaming In Recordings

MisterMac56
Frequent Visitor

XG1v4 DVR Still Shows Old Device Name After Renaming In Recordings

I changed the device name of my XG1v4 DVR, and when I go to recordings, it still shows the old device name as well as the new device name. I have restarted the XG1v4 DVR several times and it still shows the old device name, along with the new device name. I changed the XG1v4 DVR device name well over a week ago. There is no provision to delete the old XG1v4 DVR name that I can see going through all of the menus.

 

Any suggestions on how to resolve this issue?

 

Thanks!

 

OtisDowdy
New Poster

Re: XG1v4 DVR Still Shows Old Device Name After Renaming In Recordings

I'm having the same issue. I had to replace two bad X1 TV boxes, which I gave new unique names. But the names of the old X1 boxes that I no longer have still show up in my recorded devices list. No one I talk to at Comcast / Xfinity knows how to delete or remove them.
RobertWy
Silver Problem Solver

Re: XG1v4 DVR Still Shows Old Device Name After Renaming In Recordings


@OtisDowdy wrote:
I'm having the same issue. I had to replace two bad X1 TV boxes, which I gave new unique names. But the names of the old X1 boxes that I no longer have still show up in my recorded devices list. No one I talk to at Comcast / Xfinity knows how to delete or remove them.

 

What device did  use to rename your DVR?

 


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
EG
Expert

Re: XG1v4 DVR Still Shows Old Device Name After Renaming In Recordings

.@RobertWy Which poster are you replying to ?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
MisterMac56
Frequent Visitor

Re: XG1v4 DVR Still Shows Old Device Name After Renaming In Recordings

I am the original poster of this thread. I used the actual devices to change the names. I dropped DVR service and returned the X1 devices back in June. I decided to add DVR service and a XG1v4 DVR last week. And even after cancelling the DVR service back in June, and it has been three months, the old phantom devices are STILL listed under the recordings menu.

 

So there is a database somewhere in Comcast's system that is retaining non-existing X1 devices, even devices that were returned and removed from an account. There needs to be a deep dive by the advanced team to fix this huge bug.

MisterMac56
Frequent Visitor

Re: XG1v4 DVR Still Shows Old Device Name After Renaming In Recordings

Thanks for the kudos Otis! Please read my new response in this thread. The problem still exists for me, even after dropping X1 DVR service back in June and adding it back last week.