Community Forum

XG1V4 Cable Box constantly resets video resolution to 480p for a 4K TV

Highlighted
Frequent Visitor

XG1V4 Cable Box constantly resets video resolution to 480p for a 4K TV

Hello,

 

I am dealing with a very annoying issue of the Xfinity XG1V4 K Cable Box resetting itself to a Video resolution to 480p even after going into the Video Preferences and setting the resoltion to 2160p (Best Available).   The configuration I am using is the XG1V4 connected to a Marantz receiver (Model SR5014) via an HDMI cable to the CBL/SAT HDMI Input.  The Marantz receiver is connected to the Sony 4K TV (Model XBR-65X900F) from the Marantz Monitor 1 output to the Sony HDMI 1.

 

This kind of configuration has worked for years and has NEVER resulted in this constant resetting of Video resolution.  I have seen other posts regarding this issue and I do not think my situation is unique.  I have seen the suggestion of connecting the Cable Box directly to the Sony and indeed it does result in the TV being a "Recognized" device in the Video resolution preferences section.  I am sure this issue would not occur with a direct link beteen the Cable Box and the TV.  However, I want to have the benefit of the Surrond Sound system that has worked for a very long time until just recently (started exhibiting this annoying behavior about 3 weeks ago).  Of course, I have also done a full recycling/rebooting of the Cable Box several times and it does not make a difference.  I also update firmware on the Marantz receiver as well as the Sony TV regularly.  Another data point is that the HDMI cables are new and support bi-directional data flow/ARC.  I am not using ARC for this configuration as I have found it to be very buggy.

 

Is there any planned firmware update that will prevent this constant resetting of video resoluton settings.  Every time we turn on the TV, we have to go through the setup menu and reset the video resolution.  The good news is that it looks great while watching the TV.  But after powering the system off then back on again, the resolution is reset.  Please provide some guidance on how this issue can be resolved without losing th capability of using my audio receiver.  

 

A related thread is the following showing that there are others with this issue.  https://forums.xfinity.com/t5/X1/XG1v4-Jumping-to-4k-Resolution/td-p/3346892

 

 

Highlighted
Expert

Re: XG1V4 Cable Box constantly resets video resolution to 480p for a 4K TV


@JohnFinocc wrote:

Hello,

 

I am dealing with a very annoying issue of the Xfinity XG1V4 K Cable Box resetting itself to a Video resolution to 480p even after going into the Video Preferences and setting the resoltion to 2160p (Best Available).   The configuration I am using is the XG1V4 connected to a Marantz receiver (Model SR5014) via an HDMI cable to the CBL/SAT HDMI Input.  The Marantz receiver is connected to the Sony 4K TV (Model XBR-65X900F) from the Marantz Monitor 1 output to the Sony HDMI 1.

 

This kind of configuration has worked for years and has NEVER resulted in this constant resetting of Video resolution.  I have seen other posts regarding this issue and I do not think my situation is unique.  I have seen the suggestion of connecting the Cable Box directly to the Sony and indeed it does result in the TV being a "Recognized" device in the Video resolution preferences section.  I am sure this issue would not occur with a direct link beteen the Cable Box and the TV.  However, I want to have the benefit of the Surrond Sound system that has worked for a very long time until just recently (started exhibiting this annoying behavior about 3 weeks ago).  Of course, I have also done a full recycling/rebooting of the Cable Box several times and it does not make a difference.  I also update firmware on the Marantz receiver as well as the Sony TV regularly.  Another data point is that the HDMI cables are new and support bi-directional data flow/ARC.  I am not using ARC for this configuration as I have found it to be very buggy.

 

Is there any planned firmware update that will prevent this constant resetting of video resoluton settings.  Every time we turn on the TV, we have to go through the setup menu and reset the video resolution.  The good news is that it looks great while watching the TV.  But after powering the system off then back on again, the resolution is reset.  Please provide some guidance on how this issue can be resolved without losing th capability of using my audio receiver.  

 

A related thread is the following showing that there are others with this issue.  https://forums.xfinity.com/t5/X1/XG1v4-Jumping-to-4k-Resolution/td-p/3346892


put the set top box HDMI cable directly to the TV on a 4k capable port (manuals usually say HDMI1 or HDMI2). then once picture is right connect the TV's ARC connector (HDMI) to the ARC input HDMI port on the Marantz receiver. The problem is that the EDID  code of the TV is not being read properly through the receiver.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: XG1V4 Cable Box constantly resets video resolution to 480p for a 4K TV

Thanks for the tip as it worked nicely.  

 

I ran the HDMI cable from the Cable Box to HDMI 2 on the TV, then ran another HDMI cable from the Receiver ARC output to the TV Arc input.  After configuring the appropriate settings on the TV and the receiver so that the HDMI controlled the power and volume from the TV, I was able to get picture and sound last night.  The great news was that the cable box retained the correct resolution this morning.  It makes sense as when going to Display Preferences on the Cable Box, the TV is now detected as Sony 4K.  Previously, it went as Undetected.  

 

I was hesitant because I had an Arc setup before but I had issues with it.  I believe it was because I had not configured it properly.  In the past, I ran the Xfinity HDMI into the receiver, then had the Arc connection between the TV and the receiver.  Each day, I had to unplug the receiver to get a picture as the picture would disappear.  

 

Thanks again for the advice.  The only question is what do people do who do not have the benefit of the Arc feature on their TV or receiver?   I am satisfied with the solution as I probably should have configured it this way all along.  But I am sure there are people who cannot do this setup to get the benefit of surround sound with the Xfinity cable.

Highlighted
New Poster

Re: XG1V4 Cable Box constantly resets video resolution to 480p for a 4K TV

i had this exact same problem and the way around was having to direct connect cable box to tv, for my samsung 4k tv to be "recognized". then i had to buy the cable called optical digital audio out cable. your tv will have this port and you have to run that to your reciever to use the home theater and cable at the same time if you have the same setup as me where you are having to bypass reciever to recognize tv and tap into 4k channels.