Community Forum

XG1-a TV box and WiFi pod

Highlighted
New Poster

XG1-a TV box and WiFi pod

I just got an XG1 TV box. It came with a coaxial cable and the instructions say to use that to hook up to the router. However, the router is not close to the TV, so I was instructed to use an XFi pod, which has an ethernet hookup, but no coax hook up. So, I'm trying to hook up the TV box to the Xfi pd using an ethernet cable. I get the welcome message, but then there's an error message saying something went wrong. Will this ethernet connection just not work? Thanks.

Highlighted
Diamond Problem Solver

Re: XG1-a TV box and WiFi pod

I’m not sure what instructions you received but you don’t need the Internet to get that box going at all just a live coax signal

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
New Poster

Re: XG1-a TV box and WiFi pod

The problem is, there is nothing at all to plug into close to the TV. That's why I was relying on the XFi pod as the remote cable TV source, then was going to hard wire the TV box to the pod with the ethernet cable. 

Highlighted
Diamond Problem Solver

Re: XG1-a TV box and WiFi pod

Sorry, you need a live coax not Ethernet.

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!