Community Forum

X1 pauses and pixelates every few seconds

Highlighted
New Poster

X1 pauses and pixelates every few seconds

Router was setup in the basement despite my request to set it up on main level. Now every Sunday I have the joy of watching football games that pause and pixelate every few seconds. I’ve called customer support and they’ve been unable to resolve these issues due to faulty installation. I’ve tried device and system restarts including restarting my internet gateway, pressing the WPS button etc. Nothing has resolved these issues.

How do I get someone from xfinity to come out here and install it correctly? Preferably a technician who speaks and understand English fluently. This is just ridiculous at this point. Any suggestions?
Expert

Re: X1 pauses and pixelates every few seconds


@jrcoolio wrote:
Router was setup in the basement despite my request to set it up on main level. Now every Sunday I have the joy of watching football games that pause and pixelate every few seconds. I’ve called customer support and they’ve been unable to resolve these issues due to faulty installation. I’ve tried device and system restarts including restarting my internet gateway, pressing the WPS button etc. Nothing has resolved these issues.

How do I get someone from xfinity to come out here and install it correctly? Preferably a technician who speaks and understand English fluently. This is just ridiculous at this point. Any suggestions?

is your X1 set top box an xi5 or xi6 (wifi connected) set top box?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!