Community Forum

X1 audio through my pioneer receiver -help!

Highlighted
Frequent Visitor

X1 audio through my pioneer receiver -help!

Hey everyone,

New to x1. For years I have had frontier (old at&t uverse). My cable box has always been connected through HDMI to the sat/cab HDMI port on my receiver.

Then I have one main HDMI cord from my receiver out to the ARC port on my LG e8 tv.

I changed nothing else when I went from frontier to x1. All cables and settings are the same on tv and receiver. With frontier when I wanted to hear audio from the receiver versus the tv I just had to turn the receiver on and I had audio.

Now with frontier I get video no problem on the tv. I get audio no problem when using the internal tv speakers. But once I put the receiver on nothing I do seems to get the audio from signal of the x1 box to play on my surround speakers.

Help please!!!!
Highlighted
Expert

Re: X1 audio through my pioneer receiver -help!

ARC is for passing audio 'to' the sound bar from the sources connected to the TV. use a regular HDMI port (check to be sure port is 4k capable if you have a 4k set top box).



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: X1 audio through my pioneer receiver -help!

Thank you. Any idea though why everything worked fine with the frontier box but not Comcast?
Highlighted
Diamond Problem Solver

Re: X1 audio through my pioneer receiver -help!

Apples and oranges for equipment. Does your receiver pass 720p, that’s the box default.

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
Frequent Visitor

Re: X1 audio through my pioneer receiver -help!

Receiver can handle 4k and upscale.
It's a pioneer sc1522k.

I think it has to be a setting issue. Video is fine but no audio at all.

1080p is what the Comcast settings show as being handled at the moment.
Highlighted
Frequent Visitor

Re: X1 audio through my pioneer receiver -help!

I now have an optical cable connected from the x1 box out to the receiver. So now the x1 box is connected by HDMI to my receiver and optical cable from x1 to my receiver.

Still no sound when the receiver is turned on. It's passing the signal through to the tv and tv plays audio from its internal speakers but nothing I do can get Comcast source audio through my receiver speakers


Help please!
Highlighted
Expert

Re: X1 audio through my pioneer receiver -help!


@Enzodast wrote:
I now have an optical cable connected from the x1 box out to the receiver. So now the x1 box is connected by HDMI to my receiver and optical cable from x1 to my receiver.

Still no sound when the receiver is turned on. It's passing the signal through to the tv and tv plays audio from its internal speakers but nothing I do can get Comcast source audio through my receiver speakers


Help please!

you would need to consult your receiver owner's manual. note that modern receivers do not need the optical path as the HDMI cable is carrying digital audio along with video to the receiver.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: X1 audio through my pioneer receiver -help!

Trying anything I can. I have the HDMI going to the receiver. Was hoping the optical cable might help and do something since the Comcast box does have the optical out...
The HDMI is clearly working, my receiver properly passes the signal (video and audio) to the tv. I get video and audio from the tv and it's internal speakers. But once I turn on the receiver the video continues to play on the tv but the audio does not shift to my surround sound I get no audio at all when the receivers on even though I'm getting picture. I think it's a settings issue somewhere but can't find where. I've been on with Comcast customer service for an hour and I've learned nothing new at this point.

Everything worked fine with previous DVR from frontier. So receiver settings and cable connections should all be fine. Only need variable introduced was Comcast dvr.
Highlighted
Diamond Problem Solver

Re: X1 audio through my pioneer receiver -help!

Instead of Comcast, try working with Pioneer
https://www.pioneerhomeusa.com/contact-support/

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
Bronze Problem Solver

Re: X1 audio through my pioneer receiver -help!

For me - I have my X1 box connected by HDMI to my TV and by optical to my SONY receiver.  Works fine every time.

Highlighted
Frequent Visitor

Re: X1 audio through my pioneer receiver -help!

I get that should work but it impacts the usability and purpose of my receiver. That's designed as the central hub. I shouldn't have to have two long hdmi cables to make everything work. Onto pioneer next to see if they can help.