Community Forum

X1 DVR HDMI Signal Failure

Lv116
Regular Visitor

X1 DVR HDMI Signal Failure

My X1 DVR which is a couple of months old, no longer outputs a HDMI signal to my Samsung TV. I have ruled out bad cables or HDMI ports on the TV as all combinations (3 different cables and two ports) still work with my Apple TV. I get the “welcome” screen during DVR boot up then the blue screen of death. Now the Xfinity app won’t even recognize the box in the network. It had been making a noisy hard drive like sound that has now stopped. I get “0000” on the display. Scheduled an appointment of service, with the soonest being two days from now. Getting sick of Comcast.
Rustyben
Expert

Re: X1 DVR HDMI Signal Failure


@Lv116 wrote:
My X1 DVR which is a couple of months old, no longer outputs a HDMI signal to my Samsung TV. I have ruled out bad cables or HDMI ports on the TV as all combinations (3 different cables and two ports) still work with my Apple TV. I get the “welcome” screen during DVR boot up then the blue screen of death. Now the Xfinity app won’t even recognize the box in the network. It had been making a noisy hard drive like sound that has now stopped. I get “0000” on the display. Scheduled an appointment of service, with the soonest being two days from now. Getting sick of Comcast.

is your TV a 4k capable device? the STB seems to have died. If you have or plan to get a 4k TV ask the tech for the newest DVR. it is 4k very small and has no clock on the front. the app has no connection with your home DVR. what is happening when you start the app while it is connected to your own home wifi?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Lv116
Regular Visitor

Re: X1 DVR HDMI Signal Failure

My TV is not 4K but I may soon upgrade to one. It is a 720P plasma screen. The Apple TV box is 4K and works fine on both HDMI ports of the TV and with all three cables I have. The xfinity support website app initially could recognize the DVR and reset it remotely (like customer service does). Then it started saying it could not recognize the DVR on the network. I tried a few manual reboots with the power cord. I still get welcome screen then blue screen and 0000 on the display (no current time). The bad hard drive noise got so bad after a couple hours I just unplugged the power. I could clearly hear the noise from 30 feet away, while standing next to a running dishwasher. This DVR is toast. I’ll ask for a 4K capable one.
ComcastJosephB
Official Employee

Re: X1 DVR HDMI Signal Failure

@Lv116, I completely understand why dealing with this DVR issue would be exhausting. It sounds like you have done a tremendous amount of troubleshooting. We want to make sure this issue gets fixed. How did your appointment go? Did we make repairs at the location or exchange your DVR?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!