Community Forum

X1 Box does not start

Highlighted
New Poster

X1 Box does not start

I got the X1 Box today and it does not start. I tried various power outlets, tried pushing the power bottom thousand times or press for several minutes, tried reconnecting all cables, but none of them works. Is it a problem with the box itself?

Highlighted
Diamond Problem Solver

Re: X1 Box does not start

Could be the box, could be the power supply. Swap them both if you aren’t getting power

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
New Poster

Re: X1 Box does not start

Hi, thanks for the reply. How I can get them switched? All I can get to is a bot and they are not helping.
Highlighted
Diamond Problem Solver

Re: X1 Box does not start

It’s escalated to an Official Employee to see if they can help you out. Expect a response here

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
Official Employee

Re: X1 Box does not start

Hi rtatsuhira. Thank you for joining the Xfinity Forums and for creating your first post. We're sorry you are experiencing issues with your box. I can assist with placing an order to ship you a new cable box. To get started, please send me a private message and include your full name so I can assist you.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!