Community Forum

TV won't get past the welcome screen

Highlighted
New Poster

TV won't get past the welcome screen

Had a TV that would not respond to commands.   Changed batteries in remote.  Tried to re-set the TV from online service.   System responds that it cannot reach the box.   Unplugged box for 3 mintues, re-started.  TV re-starts, but won't get past the welcome screen.  

 

Now what?

 

Only one TV affected, two others are working fine.   Internet is working.

New Poster

Re: TV won't get past the welcome screen

I have the same issue, did exactly the same steps you did. my issues started 10-07-2020.

not resolved yet.

Highlighted
Expert

Re: TV won't get past the welcome screen


@davidjwood wrote:

Had a TV that would not respond to commands.   Changed batteries in remote.  Tried to re-set the TV from online service.   System responds that it cannot reach the box.   Unplugged box for 3 mintues, re-started.  TV re-starts, but won't get past the welcome screen.  

 

Now what?

 

Only one TV affected, two others are working fine.   Internet is working.


do you have other set top boxes that are working? what is the model number (on label).



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: TV won't get past the welcome screen

Thanks for replying.   As noted in my original post, I have two other TVs (with their own boxes) that were/are working fine.

 

I eventually noted in a similar thread a recommendation to unplug the box for at least 15 minutes, re-plug it in, and . . . wait.  

 

I did that (20 minutes unplugged), then re-started the system.   Got the "Welcome" screen agtain.  No progress for 30 minutes.   Went to bed, left it on.   It resolved overnight, working now.

 

I don't know if this is the official solution . . . basically, lose service for the evening . . . (pretty stupid if that is the only thing Comcast can offer).   But it "works".

Highlighted
Expert

Re: TV won't get past the welcome screen


@davidjwood wrote:

Thanks for replying.   As noted in my original post, I have two other TVs (with their own boxes) that were/are working fine.

 

I eventually noted in a similar thread a recommendation to unplug the box for at least 15 minutes, re-plug it in, and . . . wait.  

 

I did that (20 minutes unplugged), then re-started the system.   Got the "Welcome" screen agtain.  No progress for 30 minutes.   Went to bed, left it on.   It resolved overnight, working now.

 

I don't know if this is the official solution . . . basically, lose service for the evening . . . (pretty stupid if that is the only thing Comcast can offer).   But it "works".


if they are working go to each and use voice command "about" and reply with each device's model shown to the right of STB Version.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!