Community Forum

Prime & CBSAllAccess won't play videos - get errors

coloradon8tive
Regular Visitor

Prime & CBSAllAccess won't play videos - get errors

I have Prime and All Access on my Roku and they work fine, but on X1 (preferred method of using those apps), I can navigate to a video, etc but when clicking to watch the video, I get an error.  HBO and Peacock work just fine.

 

I tried "refreshing", I tried unplugging both router and x1 box and waiting a couple minutes and plugging back in to "reset".

 

I can't find how to update an app on x1 like say i would on roku.  I can find the last update to my X1 system ,but no info on the apps themselves - it's like I have to just wait and hope it cures itself

ComcastStarr
Official Employee

Re: Prime & CBSAllAccess won't play videos - get errors

Hi, @coloradon8tive! I hate to hear of the issues you're having connecting to these apps. I also prefer to watch my Prime shows directly from my X1 box. I find it so much easier to do it that way. Please send me a private message with your name and address so I can help you figure this out. Just click on my name, "ComcastStarr" and click "send a message" from there we can figure this out and look at your equipment specifically. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!